Closed Bug 471959 Opened 11 years ago Closed 9 years ago

[SeaMonkey] test_bug458898.html reports incorrect innerWidth/innerHeight

Categories

(Core :: Layout, defect, major)

defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla2.0b11
Tracking Status
status1.9.2 --- wontfix
status1.9.1 --- wontfix

People

(Reporter: sgautherie, Assigned: sgautherie)

References

(Blocks 1 open bug)

Details

(Whiteboard: [perma-orange])

Attachments

(1 file)

Bug 469331 comment 17:
{
*Firefox  : window looks fine, innerWidth=117 innerHeight=216 :-)
*SeaMonkey: window looks fine, innerWidth=104 innerHeight=0   :-(

Maybe one of these bugs:
https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=anywordssubstr&short_desc=innerWidth+innerHeight&resolution=---
}

{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1230973665.1230977756.14287.gz&fulltext=1
Linux comm-central dep unit test on 2009/01/03 01:07:45

*** 42322 INFO TEST-KNOWN-FAIL | /tests/layout/base/tests/test_bug458898.html | innerWidth: 1 >= 100 ?
*** 42323 INFO TEST-KNOWN-FAIL | /tests/layout/base/tests/test_bug458898.html | innerHeight: 1 >= 200 ?

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1230977253.1230983446.28690.gz&fulltext=1
MacOSX 10.4 comm-central dep unit test on 2009/01/03 02:07:33

*** 42340 INFO TEST-KNOWN-FAIL | /tests/layout/base/tests/test_bug458898.html | innerWidth: 0 >= 100 ?
*** 42341 INFO TEST-KNOWN-FAIL | /tests/layout/base/tests/test_bug458898.html | innerHeight: 0 >= 200 ?

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1230974491.1230979204.17483.gz&fulltext=1
Win2k3 comm-central dep unit test on 2009/01/03 01:21:31

*** 42350 INFO TEST-PASS | /tests/layout/base/tests/test_bug458898.html | innerWidth: 104 >= 100 ?
*** 42351 INFO TEST-KNOWN-FAIL | /tests/layout/base/tests/test_bug458898.html | innerHeight: 0 >= 200 ?
}
Reminder: my local m-c + c-c Windows SM build confirms this on trunk Core too.
Flags: wanted1.9.1?
Duplicate of this bug: 472886
Flags: blocking1.9.1?
(In reply to comment #1)
> *** Bug 472886 has been marked as a duplicate of this bug. ***

In bug 469331 comment 2, KaiRo reported he gets an invisible window on his Linux(+1.9.1),
whereas I get a visible window on my Windows+trunk (bug 469331 comment 17).

He did not confirm whether this is still the case currently,
so I (still) wonder if this possible different behavior could be related to the Windows innerWidth test being the only one to report the expected value...
Flags: wanted1.9.1?
Flags: wanted1.9.1+
Flags: blocking1.9.1?
Flags: blocking1.9.1-
This just/eventually got fixed by something in
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6fbc3c08894e&tochange=d545aa98feb1
:-)

{
593 ERROR TEST-UNEXPECTED-PASS | /tests/layout/base/tests/test_bug458898.html | innerWidth: 117 >= 100 ?
594 ERROR TEST-UNEXPECTED-PASS | /tests/layout/base/tests/test_bug458898.html | innerHeight: 216 >= 200 ?
}

***

SeaMonkey ignores m-1.9.2.
I assume the underlying issue will not be fixed on m-1.9.1: we'll see.
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla2.0b11
Blocks: SmTestFail
Attachment #508761 - Flags: review?(dbaron) → review+
Comment on attachment 508761 [details] [diff] [review]
(Av1) Revert workaround from bug 469331, now that the underlying m-c bug is fixed
[Checked in: Comment 5]

http://hg.mozilla.org/mozilla-central/rev/1c2d53a2dcfb
Attachment #508761 - Attachment description: (Av1) Revert workaround from bug 469331, now that the underlying m-c bug is fixed → (Av1) Revert workaround from bug 469331, now that the underlying m-c bug is fixed [Checked in: Comment 5]
Severity: normal → major
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Hardware: x86 → All
Resolution: --- → FIXED
Whiteboard: [perma-orange]
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1296633662.1296637297.15240.gz
OS X 10.6 comm-central-trunk debug test mochitests-4/5 on 2011/02/02 00:01:02
{
593 INFO TEST-PASS | /tests/layout/base/tests/test_bug458898.html | innerWidth: 117 >= 100 ?
594 INFO TEST-PASS | /tests/layout/base/tests/test_bug458898.html | innerHeight: 216 >= 200 ?
}

V.Fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.