If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

when many tab windows are open (e.g., 20 or more), Firefox frequently freezes

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Ken Benton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

I often have firefox running with multiple tabs open (20 or more). This makes Firefox unstable and it frequently freezes, especially if an additional window-- for example, if I try to attach a file for a gmail message, the "browse" window to locate the file results in firefox freezing. It also happened when I opened up the download window to open a download. The opening of the download windows caused firefox to freeze (again this only happens when a large number of tabs are open).

I used to run multiple tabbed windows in earlier versions of Firefox (since the tabbed was first released), and did not have this problem. There seems to be a bug causing Firefox to freeze because a large number of open tabs.

Reproducible: Always

Steps to Reproduce:
1. open firefox with 30 tabs (this also happens if you multiple tabs and a new browser windows (i.e., control-N and multiple tabs)
2.  go to a web page where you need to perform a "browse file" to open an attachment-- for example, go to gmail, compose an email, and try to attach a file to the email
3.   This should cause firefox to become unstable and freeze.
Actual Results:  
firefox froze

Expected Results:  
not become frozen

I run vista 64-bit
Can you reproduce this if you run Firefox in teh Firefox safemode ?
http://support.mozilla.com/en-US/kb/Safe+Mode

Comment 2

8 years ago
I opened 65 windows and could not reproduce, please reopen if you can in safe mode.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.