If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Search+Reports give Internal Server Error

RESOLVED WORKSFORME

Status

Testopia
General
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Johannes Buchner, Assigned: Greg Hendricks)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 355240 [details] [diff] [review]
absolute addressing of function

Hi!

I noticed that the 3.2 bugzilla patched with the testopia 2.2 Beta I downloaded today crashes when I try to use the search page (just opening it), or the Reports.

The html output is:

The server log is (for each request):
[Sat Jan 03 17:18:34 2009] [error] Undefined subroutine &ModPerl::ROOT::ModPerl::Registry::var_www_html_bugs_query_2ecgi::editable_bug_fields called at /var/www/html/bugs/query.cgi line 238.\n
where /var/www/html/bugs is my bugzilla install directory and _2e is ?.

My Perl configuration looks like this:

<Location />
      AddHandler perl-script .cgi .pl
      PerlHandler ModPerl::Registry
      PerlSendHeader On
      PerlOptions +ParseHeaders
      AllowOverride None
      Order Deny,Allow
      Allow from all
</Location>
LoadModule perl_module modules/mod_perl.so
PerlModule Apache2::compat
PerlOptions +GlobalRequest
PerlSwitches -I/var/www/html/tests  -I/var/www/html/bugs -I/var/www/html/bugs/ -I/var/www/html/bugs/lib -w -T
PerlConfigRequire /var/www/html/bugs/mod_perl.pl



I fixed it with the attached patch (1 Line). Please move if it is a Bugzilla bug. 



Regards,
Johannes
(Assignee)

Comment 1

9 years ago
Likewise to bug 472435
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.