regression: Unable to enter text into the body of compose window

VERIFIED DUPLICATE of bug 4668

Status

MailNews Core
Composition
P3
critical
VERIFIED DUPLICATE of bug 4668
19 years ago
9 years ago

People

(Reporter: fenella, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
RE: Seamonkey Win32 build (Apr07 03:27:00)
In the mail Compose window, there is NO cursor focus, no blinking vertical bar
and therefore unable to compose message in the Message Compose window
Steps:
1. Execute apprunner.exe
2. Select Messenger from the Tasks menu
3. Click on New Msg to open the Compose window
4. Type text in the Address field, no problem. But I do not see a cursor focus
or blinking vertical bar in the compose area.
Actual result: No cursor focus, message compose area is NOT enabled. Unable to
compose message. This problem did not exist in the previous builds.
Expected result:  should have a cursor focus and be able to enter text in the
message compose window.

Updated

19 years ago
Summary: Unable to compose mail message in the Compose window → Unable to compose mail message in the Compose window

Comment 1

19 years ago
Fenella, even though there is no focus in the message body area of the compose
window, can you still type text in there?

cc: kostello in case this is ender-related.

Scott, do you have this problem?

Comment 2

19 years ago
Yes, I have this problem.  I can't type in the widget.

Updated

19 years ago
Severity: major → critical
Summary: Unable to compose mail message in the Compose window → regression: Unable to enter text into the body of compose window

Updated

19 years ago
Target Milestone: M4

Comment 3

19 years ago
This is a regression from M3, and as such, is a M4 stopper.  I'll go ahead and
mark as such to get this bug on chofmann and leger's overall query radar.
Jean-Francois, if this is not your bug, pls reassign accordingly. Thanks.
(Reporter)

Comment 4

19 years ago
Lisa, No.  I am NOT able to type any text at all. I did a right click in the
body and type text, no response, no text appears at all.

Comment 5

19 years ago
FYI...Strange cases of reproducing this bug with today's build 1999040809.
mscott and nbaca could type in the body on Win NT4.0 today, I still can't with
Win95. nbaca can't when she switches to Win95 on her dual boot system using the
same seamonkey build she used on NT 4.0.  Scott P. and Fenella were both using
NT 4.0 when they saw the bug.

Updated

19 years ago
Assignee: ducarroz → kostello

Comment 6

19 years ago
I believe this is an editor bug with windows 95/98. I ran the editor test
harness on a win 95 machine and was unable to enter text into their editor test
bed.

Jean-Francois, I hope you don't mind but I'm going to send this over to kostello
so his team can take a look.

If someone still sees this bug today with NT let me know. But the few NT
machines we've tried today have worked. Win95 has been the trouble maker.

Comment 7

19 years ago
On Fenella's NT4.0 she still can't type text in Compose body with todays
1999040809 build. Scott P. how about you.

Comment 8

19 years ago
using my debug build that was updated right before lunch on NT 4.0 I can't type
into the compose window.
(Assignee)

Comment 9

19 years ago
Does Editor as a read only mode feature?

Comment 10

19 years ago
cc: sujay@netscape.com.  Sujay, mscott's comments are: "I ran the editor test
harness on a win 95 machine and was unable to enter text into their editor test
bed."  Do you know if there is an open bug on this in the Editor area already?

Comment 11

19 years ago
Fenella, since this bug happens on your system consistently, can you keep an eye
out for it?  When it's marked fixed and new builds are available, pls verify
this bug from the mail compose window.  Thanks.

Updated

19 years ago
QA Contact: 4080 → 4104
(Assignee)

Comment 12

19 years ago
This bug doesn't seems to occurs all the time for me. I am working in NT4.
(Reporter)

Comment 13

19 years ago
RE: Win32 april 8 evening build (apr 08 10:41:00)
This problem still exits in my machine, which is HP X86, family 6, 233 MHZ, 32
MB, 4GA. I will continue to monitor this problem in the next build.

Comment 14

19 years ago
on my NT box, using code from 4/8 at around 11:00pm, I cannot type into compose
window.  Looking in debugger, the editor constructor never even gets called.
The editor testbed (apprunner -editor) works fine.

Comment 15

19 years ago
Steve Clark started to look into this bug. It turns out the editor is not
getting constructed at all. Since typing in the editor testbed works, we are
going to investigate to see if it doesn't have something to do with the XUL
file.

Updated

19 years ago
Assignee: kostello → ducarroz

Comment 16

19 years ago
jefft and I just looked at this. The manifestations are:
1. First compose window works fine; the editor gets intantiated,
   everything works.
2. Second or subsequent compose windows don't work; they use the same editor
   appcores that was instantiated the first time, but in the call to
   setContentWindow, the content viewer in the webshell obtained from that
   window is null, so DoEditorMode fails.

I'm pretty sure this is not an editor problem. It might be either a side-effect
of the massive webshell leakage (bug 4127), or some other appcores/XUL problem
with the mail compose window. Reassigning to ducarroz.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 17

19 years ago
OK, I looked at the xul code and based on what Simon is saying, this is a
duplicate of 4668 which has hit me in other less important areas.  Startup is
being called from onload which we know from 4668 doesn't work correctly.  I'm
going to make this a duplicate of that bug and copy Simon's message into the
other bug.

*** This bug has been marked as a duplicate of 4668 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

19 years ago
Status: VERIFIED → REOPENED

Comment 18

19 years ago
I think we are being too hasty here =). Simon, did you and Jeff try this out on
a win98/95 machine? The bug we're trying to report is that BOTH the editor and
the mail compose editor widget cannot be typed into on win95/98. I see buster
also looked into this bug but only on NT.

If the editor is DOA on win95/98 how can it be a mail bug?

I do agree there may be a separate bug causing the problems we are seeing on NT
that Scott P. marked this as a duplicate of (Bug #4668).

I'm re-opening this bug. Can simon/buster or someone from the editor team verify
the problem that the editor test bed doesn't work on win 95/98? I could be
smoking something but on our QA machines it didn't work...

Comment 19

19 years ago
The bug that I marked this as a duplicate of is a timing bug.  I can't even get
the compose window to work the first time on my machine.  If the Editor Appcore
is using onload (which I haven't verified) they could just be getting lucky.

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago

Comment 20

19 years ago
Okay Simon Scott and I just reproduced the problem with the editor test bed on
Win95 and 98. I agree this could be a duplicate of the bug Scott marked it as.
QA, when verifying the bug fix, we need to verify the editor and mail compose
windows.....

*** This bug has been marked as a duplicate of 4668 ***

Comment 21

19 years ago
Bug 4668 is marked with M5 target milestone.  I've made a comment in that bug
that we need it fixed for M4.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 22

19 years ago
verifying as a duplicate then.
Will track this issue in the other bug.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.