incorrect bookmark restore order if sqlite server storage cause bookmarks in root folder

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: mozdiav, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090103 Minefield/3.2a1pre
Build Identifier: 0.2.95 hg 6ff310cc7bb7 client, hg 7c86d890cfac server

If server storage placed in sqlite, during download from server some bookmarks restores before parent folders restores. It caused wrong bookmark placement in root folder instead correct parent folder.

If server storage changes to use mysql instead sqlite, this effect not appers.

Reproducible: Always

Comment 1

10 years ago
To clarify: Igor has a server that is returning 0 for index/depth of all items.  We suspect the problem is due to his use of the sqlite backend.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Good catch. Fixed in server hg 92eb5a81e526.

Comment 3

10 years ago
Yay!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.