Bareword "SPECIAL_STATUS_WORKFLOW_ACTIONS" not allowed while "strict subs"

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: buchner.johannes, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 355301 [details] [diff] [review]
absolute addressing of constant

I patched Bugzilla 3.2 with Testopia 2.2-Beta. Please move if this is not the right place.

on
/editvalues.cgi

I get a 500 Internal Server Error

log says:

[Sun Jan 04 11:13:07 2009] [error] Bareword "SPECIAL_STATUS_WORKFLOW_ACTIONS" not allowed while "strict subs" in use at /var/www/html/bugs/editvalues.cgi line 234.\nBareword "SPECIAL_STATUS_WORKFLOW_ACTIONS" not allowed while "strict subs" in use at /var/www/html/bugs/editvalues.cgi line 448.\n


line says:

    if ($value ne $valueold) {

        unless ($value) {
            ThrowUserError('fieldvalue_undefined');
        }
        if (ValueExists($field, $value)) {
            ThrowUserError('fieldvalue_already_exists', $vars);
        }
        if ($field eq 'bug_status'
            && (grep { lc($value) eq $_ } SPECIAL_STATUS_WORKFLOW_ACTIONS))
        {
            $vars->{'value'} = $value;
            ThrowUserError('fieldvalue_reserved_word', $vars);
        }
        trick_taint($value);

grepping for it ...
seems to be defined in Bugzilla/Bug.pm : use constant SPECIAL_STATUS_WORKFLOW_ACTIONS => qw(

changing to Bugzilla::Bug::SPECIAL_STATUS_WORKFLOW_ACTIONS ... seems to work. See patch.

Comment 1

10 years ago
I cannot reproduce the problem on https://landfill.bugzilla.org/testopia/. Are you sure you ran checksetup.pl after applying the patch?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
In apache-conf I use 
<Perl>
  use utf8;
  use Apache2::compat;
  use lib '/var/www/html/tests';
  use Apache::DBI;
  use CGI;
  CGI->compile(qw(header param cookie));
  use DBI;
  DBI->install_driver("mysql");
  use Template;
  use HTML::StripScripts;
  use Text::Markdown;
</Perl>

<Location />
      AddHandler perl-script .cgi .pl
      PerlHandler ModPerl::Registry
      PerlSendHeader On
      PerlOptions +ParseHeaders
      AllowOverride None
      Order Deny,Allow
      Allow from all
</Location>
LoadModule perl_module modules/mod_perl.so
PerlModule Apache2::compat
PerlOptions +GlobalRequest
PerlSwitches -I/var/www/html/tests  -I/var/www/html/bugs -I/var/www/html/bugs/ -I/var/www/html/bugs/lib -w -T
PerlConfigRequire /var/www/html/bugs/mod_perl.pl

Maybe you can reproduce it with that?
Otherwise don't set it to RESOLVED-INVALID, but to RESOLVED-WFM.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 3

10 years ago
No idea if I can reproduce with this configuration or not. You have Testopia applied to your installation, and this clearly looks like a support question to me, which are all marked as INVALID as we don't accept support questions here. You should rather ask in the newsgroup, see http://www.bugzilla.org/support. If ghendricks thinks this is a bug in Testopia, I will let him retarget this bug to the Testopia product.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.