Thunderbird should support MSExchange redirects

RESOLVED DUPLICATE of bug 59704

Status

--
enhancement
RESOLVED DUPLICATE of bug 59704
10 years ago
10 years ago

People

(Reporter: alex.borovsky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.1b3pre) Gecko/20081204 Lightning/1.0pre Thunderbird/3.0b1

Currently thunderbird doesn't support redirects on exchange servers (in IMAP mode). It will be good, if it automatically (may by with confirmation) update connection settings.

Transcript of example IMAP session:
[alex@aborovsky ~]$ telnet uskihsvpexch23.kih.kmart.com 143
Trying 157.241.186.193...
Connected to uskihsvpexch23.kih.kmart.com.
Escape character is '^]'.
* OK Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7638.1 (uskihsvpexch23.kih.kmart.com) ready.
a001 CAPABILITY
* CAPABILITY IMAP4 IMAP4rev1 IDLE LOGIN-REFERRALS MAILBOX-REFERRALS NAMESPACE LITERAL+ UIDPLUS CHILDREN AUTH=NTLM
a001 OK CAPABILITY completed.
a002 logout
* BYE Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7638.1 signing off.
a002 OK LOGOUT completed.
Connection closed by foreign host.
[alex@aborovsky ~]$ telnet imap1.example.com 143
Trying 12.34.56.78...
Connected to imap1.example.com.
Escape character is '^]'.
* OK Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7638.1 (imap1.example.com) ready.
a001 login user password
a001 NO [REFERRAL imap://user;AUTH=*@imap2.example.com/] The requested mailbox is not available on this server.
a002 logout
* BYE Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7638.1 signing off.
a002 OK LOGOUT completed.
Connection closed by foreign host.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
It's called an IMAP Referral, FWIW.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 59704
You need to log in before you can comment on or make changes to this bug.