Unable to delete bookmarks+history url from autocomplete though BookmarkBonus = 0

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: u303387, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

I have the following settings configured to turn off bookmark searches in the Location Bar:
places.frecency.bookmarkVisitBonus = 0
places.frecency.unvisitedBookmarkBonus = 0
browser.urlbar.matchOnlyTyped = True

If the Location Bar search returns a site typed that is also a bookmark I would expect to be able to remove it from the search results with DEL or shift-DEL, as I am only searching based on typed sites. However, because these sites are also bookmarks I cannot remove them from my search results without removing the bookmark even though Firefox is not searching my bookmarks.

Reproducible: Always

Steps to Reproduce:
1. Set the following in about:config
places.frecency.bookmarkVisitBonus = 0
places.frecency.unvisitedBookmarkBonus = 0
browser.urlbar.matchOnlyTyped = True
2. Type text to find a bookmarked visited URL
3. Highlight the result
4. Hit DEL or shift-DEL to delete
5. Re-enter the text from step 2
Actual Results:  
The result reappears due to the fact that it is also a bookmark

Expected Results:  
The result should not reappear since I don't care to search by bookmarks and if I want to delete something from my history I shouldn't have to delete the associated bookmark first.

Would it be possible to allow deletion from the Location Bar results without deleting the bookmark, either 1) when the above config settings above are set or 2) generally?

The workaround of deleting a bookmark is not desirable in most cases.
This is an enhancement essentially, that the del button should delete it from the location bar, but keep it in the places db.
Severity: normal → enhancement
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
feature requests of this type won't be added to the 3.0.x branch, please try 3.6pre nightly builds.  This seems to work as you expect there.  By the way, in 3.5+= there is Preference UI to choose what you wish to appear in the Awesome Bar.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.