The save and quit option does not work if the downloads window is still opened!

RESOLVED DUPLICATE of bug 354894

Status

()

--
minor
RESOLVED DUPLICATE of bug 354894
10 years ago
10 years ago

People

(Reporter: kvaba, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 (.NET CLR 3.5.30729)

It is inconvenient that if i have not closed the downloads window and i click to close my browser i am not given the option to save my tabs. 

The program probably thinks the downloads window is another instance of Firefox running, but logically it is not!

Reproducible: Always

Steps to Reproduce:
1. Open Downloads
2. Try to save and quit
3.
Actual Results:  
i will have to close my downloads first and then save and quit, or i will not be able to save my tabs. 
it's annoying because many times i have opened lots of things and don't know that downloads is opened.

Expected Results:  
The program should not consider "downloads" as another instance of Firefox. I should be given the save and quit option on exit. and if i do click exit, the downloads should be closed automatically too.

it happens no matter the theme, options, etc...
(Reporter)

Updated

10 years ago
Whiteboard: save and quit

Updated

10 years ago
Whiteboard: save and quit → DUPEME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 354894
You need to log in before you can comment on or make changes to this bug.