[FIX]pdf (.pdf) files fail to load since 20090104 nightly

VERIFIED FIXED

Status

()

Core
DOM
P2
major
VERIFIED FIXED
9 years ago
7 years ago

People

(Reporter: u88484, Assigned: bz)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.2 +
in-litmus +

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
pdf files fail to load using 20090105 nightly on Vista and XP, not sure about linux or Mac.  No errors in the console.

Test link provided in URL input field
(Reporter)

Comment 1

9 years ago
Regression range:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7c83a7b2b24&tochange=9f497b1505d2
(Reporter)

Updated

9 years ago
Flags: blocking-firefox3.1?
(Reporter)

Updated

9 years ago
Summary: pdf (.pdf) files fail to load → pdf (.pdf) files fail to load since 20090104 nightly

Comment 2

9 years ago
Seems to be caused by bug 466384, backed it out locally and pdfs load again.
Changing procuct and component based on comment #2
Component: General → DOM
Flags: blocking-firefox3.1?
Product: Firefox → Core
QA Contact: general → general
Flags: blocking1.9.2?
Blocks: 466384
As a work-around, you can load PDF files by disabling the Adobe Reader plug-in.  This bug only impacts PDF access via the Adobe plug-in.
Created attachment 355589 [details] [diff] [review]
workaround

I consider this more of a kludge than a proper fix.  However, it does restore plug-in functionality without reverting the fix from bug 466384.

I do not intend to request review on this patch, nor do I intend to take this bug.

Comment 6

9 years ago
Hello,

this bug seems to affect also the Foxit Reader plugin (www.foxitsoftware.com). Trying to display a PDF using this plugin results in an empty page (nothing is displayed).

Kind regards.

Comment 7

9 years ago
Yes Gerd, this does affect the newest release of Foxit 3.0 (build 1301) on XP Pro SP3.  I cannot open any pdf files within the browser.  I just get an empty page.

Comment 8

9 years ago
That's interesting, it's working fine for me
- Firefox 3.2a1pre ID:20090106034601
- Foxit 3.0 (build 1301)
- WinXP SP2 (note SP2 not SP3)

Comment 9

9 years ago
I take it back, I was not opening files IN the browser

Sorry for the spam
Duplicate of this bug: 472230
same problem when an swf isn't embedded in a page
Created attachment 355786 [details] [diff] [review]
This should fix it
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #355786 - Flags: superreview?(jst)
Attachment #355786 - Flags: review?(jst)
(In reply to comment #12)
> Created an attachment (id=355786) [details]
> This should fix it

Well, I can verify that it builds under both Linux and Windows and fixes all the known regressions from bug 466384.
Great.  I'd built it on Mac and tested the quicktime thing there.  Plus it's clearly the right thing to be doing.  ;)

Thank you for testing this!  One of these days we'll have some plug-in regression tests, I hope.
Summary: pdf (.pdf) files fail to load since 20090104 nightly → [FIX]pdf (.pdf) files fail to load since 20090104 nightly
Flags: in-litmus?

Updated

9 years ago
Attachment #355786 - Flags: superreview?(jst)
Attachment #355786 - Flags: superreview+
Attachment #355786 - Flags: review?(jst)
Attachment #355786 - Flags: review+
Pushed http://hg.mozilla.org/mozilla-central/rev/96e5551239e6.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Depends on: 386676
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090109 Minefield/3.2a1pre ID:20090109110546

verified fixed on windows
Depends on: 472939
https://litmus.mozilla.org/show_test.cgi?id=7456
Flags: in-litmus? → in-litmus+

Updated

9 years ago
No longer depends on: 472939
verified fixed using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090112 Minefield/3.2a1pre.
Status: RESOLVED → VERIFIED
status1.9.2: --- → beta1-fixed
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P2
You need to log in before you can comment on or make changes to this bug.