typo in toolsrc build file (build.xml)

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: driscoll.davidj, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: rhino1_7R1 

The build file in rhino\toolsrc\build.xml has a small typo in the target compile-debugger section.
It should have destdir="${classes}" instead of  destdir="classes" otherwise compiled classes do not get copied to appropriate build location and .jar file does not include the tools classes when command: " ant compile-debugger " is run.

Reproducible: Always

Steps to Reproduce:
1.Go to \toolsrc
2.ant compile-debugger
3.notice compiled classed not copied to build folder
Actual Results:  
compiled classes do not get copied to the appropriate build folder due to this typo.

Expected Results:  
ant compile-debugger should copy .class files to \rhino\build\ 

It should have destdir="${classes}" instead of  destdir="classes"
in the target compile-debugger section.

Comment 1

10 years ago
This has been fixed in the 1.7R2 candidate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.