Using option + pageup/pagedown doesn't move the cursor in editor controls

VERIFIED FIXED

Status

()

Core
Editor
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: whimboo, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
All
Mac OS X
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090104 Shiretoko/3.1b3pre ID:20090104020455

All Apple applications support moving the cursor by using Option + PageUp/PageDown/Home/End. The view is scrolled accordingly and the cursor is set to the new position. This doesn't work in Firefox and Thunderbird (while composing a message). Means, clearing large parts of text in a compose window has to be down by holding down Shift + Cursor Up/Down/Right/Left for a while.

If it should be a regression, it's not a recent one. It is still visible in Thunderbird 2.
(Assignee)

Comment 1

8 years ago
Created attachment 391990 [details] [diff] [review]
Possible patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #391990 - Flags: review?(mstange)
Comment on attachment 391990 [details] [diff] [review]
Possible patch

Works wonderfully.
Attachment #391990 - Flags: review?(mstange) → review+
(Assignee)

Updated

8 years ago
Attachment #391990 - Flags: superreview?(bzbarsky)

Comment 3

8 years ago
I believe in order for this to work in richtext editor case, Bug 438840 needs to be fixed as well
That's correct.

Updated

8 years ago
Blocks: 438840
Attachment #391990 - Flags: superreview?(bzbarsky) → superreview+
(Assignee)

Comment 5

8 years ago
Pushed changeset 8795a7a9817c to mozilla-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

8 years ago
Sorry, but that still doesn't work for me with the external Apple keyboard or the keyboard of my MacBook Pro and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a2pre) Gecko/20090810 Minefield/3.6a2pre ID:20090810031114
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I tested this on my 10.4 Macbook with fn+Option+Arrow up/down. All the other combinations (i.e. with Shift and/or with left/right) didn't work in Cocoa applications. Do they with the external keyboard?
(Reporter)

Comment 8

8 years ago
Using the arrow keys wasn't the issue I have commented in comment 0. Those combinations work but you really cannot use it with an external keyboard. You will have to make knots in your fingers. Please see comment 0 how other applications on OS X support pageup/pagedown/home/end. Is there a HIG somewhere?
(In reply to comment #8)
> Using the arrow keys wasn't the issue I have commented in comment 0.

My Macbook keyboard doesn't have pageup/down keys. Instead there's a "page" label on my up and down arrow keys, so I assumed pressing fn+arrow up/down is the same as pageup/pagedown. Is that not the case?
(Reporter)

Comment 10

8 years ago
Seems so. Do we have a test page where we can show up keypress events so I can compare?
http://mozilla.pettay.fi/moztests/showkeys.html
(Reporter)

Comment 12

8 years ago
Ok, I was wrong. No idea why this wasn't working the last days but now after I had to restart yesterday it works. Strange. I'll remove the home and end part from the summary because this bug doesn't take care of it.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Summary: Using option + pageup/pagedown/home/end doesn't move the cursor in editor controls → Using option + pageup/pagedown doesn't move the cursor in editor controls
(Reporter)

Comment 13

8 years ago
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a2pre) Gecko/20090810 Minefield/3.6a2pre ID:20090810031114

Do we have tests for it?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Hardware: x86 → All

Comment 14

8 years ago
a test case for this is added in Bug 438840
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.