If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

URL and Forum Thread Title Mismatch

VERIFIED WONTFIX

Status

quality.mozilla.org
Website
P3
minor
VERIFIED WONTFIX
9 years ago
8 years ago

People

(Reporter: aakashd, Assigned: paulc)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081125 Minefield/3.1b2pre
Build Identifier: 

The URL of the forum post is static to when it is first set. If the title of the forum post is changed afterwards, the URL is not.

I.E. The URL of the forum thread:

http://quality.mozilla.org/forums/bugs-and-issues/qmo-help-questions-and-answer-requests

The title before: QMO Help Questions and Answer Requests
The title now: QMP Help: Q&A Requests

Reproducible: Always

Steps to Reproduce:
1. Create a forum thread with any title
2. View the forum thread title
3. Edit the forum thread's title
4. Reload the the forum thread and view the title
Actual Results:  
The URL of the forum thread does not change.

Expected Results:  
The URL of the forum thread should change? I'm not sure if this is intended. If it is, there should probably be a disclaimer to the user creating a new thread.
Mass move of bugs to new product
Status: UNCONFIRMED → NEW
Component: quality.mozilla.org → QMO: Website
Ever confirmed: true
Product: Websites → QMO
*** This bug has been confirmed by popular vote. ***

Updated

9 years ago
OS: Windows XP → All
Priority: -- → P3
(Assignee)

Comment 3

8 years ago
Having the URLs automatically change with the title changing is a bad idea, as people will be unable to find the "old url". And if you keep the old URL, you have a bunch of URLs taken up by few posts/forum threads/etc, also bad.
A user can manually change the URL anyway. I think it's fine, basically those who don't know how to set the alias are stuck with the first option.

You can potentially make this bug about allowing certain user roles to set URL paths, but not everyone.
Assignee: nobody → paul.craciunoiu
(Reporter)

Comment 4

8 years ago
yeah, this was filed before I realized that people with admin rights had the ability to change the aliasing for the forum links (or anything in that manner). We can set this to resolved:wontfix.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

8 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.