The install.rdf in iMacros falsely claims compatibility with Mozilla Suite and SeaMonkey 1.1

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
minor
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: Philip Chee, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
https://addons.mozilla.org/en-US/firefox/addon/3863

The install.rdf in iMacros falsely claims compatibility with Mozilla Suite and SeaMonkey 1.1 when the root of the XPI doesn't contain a |install.js| file. In addition it is highly unlikely that even if it does that it would work in Mozilla Suite 1.7 (a Gecko 1.7 based application).

    <!-- Mozilla Suite -->
    <em:targetApplication>
      <Description>
        <em:id>{86c18b42-e466-45a9-ae7a-9b95ba6f5640}</em:id>
        <em:minVersion>1.6</em:minVersion>
        <em:maxVersion>1.8</em:maxVersion>
      </Description>
    </em:targetApplication>

    <!-- SeaMonkey -->
    <em:targetApplication>
      <Description>
        <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
        <em:minVersion>1.0</em:minVersion>
        <em:maxVersion>1.1</em:maxVersion>
      </Description>
    </em:targetApplication>
I think this should be raised directly with the author via the support link. Addon bugs don't really belong in bugzilla.
Can we resolve this invalid?
(Reporter)

Comment 2

9 years ago
I don't use iMacros myself. I am a SeaMonkey developer trying to help a user who says he can't install iMacros in SeaMonkey due to the "no install script found" error.

Perhaps you could move this extension back to experimental/sandbox until this is fixed?
(Reporter)

Comment 3

9 years ago
Perhaps we can morph this bug. During the upload process the install.rdf in the XPI is already scanned for application compatibility information (and is rejected if the max/min/version is out of range). How difficult is it to say if compatibility with Mozilla Suite (any version) or SeaMonkey 1.0-1.1.x is detected .AND. there is no "install.js" file in the root of the XPI, to reject this upload?
I think that would be fair. Though, going into the future this might be less useful as newer applications use install.rdf
I sent the author an email
Reply from the author:
---------------------------------------------

Hello Wil,

Thanks a lot for the email. I confirmed the issue.

I just uploaded a new XPI to AMO (iMacros V6.1.1.4) where I removed the the claim of compatibility until we have time to test this further and fix the issue.

Thanks for your hint!

Regards,
Mathias 
---------------------------------------------
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.