Printing to Adobe PDf-Writer produces garbage in FF3.0.5 , not in previous versions

RESOLVED DUPLICATE of bug 454532

Status

()

--
major
RESOLVED DUPLICATE of bug 454532
10 years ago
10 years ago

People

(Reporter: pslingard, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Since updating to Firefox 3.0.5 i can no longer print downloaded forms or downloaded html pages CLEANLY. Instead of the output in the resulting pdf file being READABLE by english -speaking human beings, it looks as if there has been character substitution corrupting the output to make it unreadable. 

I note that Rich Alcorn reported this last August (2008) , and my problem is substantially the same.  My pdf-writer is from Adobe's Acrobat vers. 4.05; and it has worked cleanly in all other versions of Firefox (I have been with you since the beginning) and used Netscape prior to that!

Is the nothing you can do to fix this simple bug?



Reproducible: Always

Steps to Reproduce:
1. Download to FF 3.0.5 or File-open from a folder any html file with text and image content. 
2. Print all or part of it to pdf using Adobe PDF Writer (an installed virtual printer) 
3. The text in the printed file copy (eg.  nnnn.pdf) will be corrupted by character substitution, some of which is symbol oriented. 
Actual Results:  
The ascii text in the output pdf-file is unreadable because each character has been substituted by another , seemingly at random - but there may be some cipher being applied. 

Expected Results:  
A normally readable ENGLISH Language file replicating the LAYOUT (INCLUDING IMAGES) of the on-screen page or form  from which the file printout WAS ORDERED BY THE USER ie by using the menu function File/Print (Properties set to PDF-Writer virtual printer) . 

The pages print normally to an HP3055 laser all-in-one or Canon BJ 200 printer.

Comment 1

10 years ago
Is this bug 454532?
(Reporter)

Comment 2

10 years ago
Created attachment 355741 [details]
Example of this bug report printed from FF 3.0.5
(Reporter)

Comment 3

10 years ago
Created attachment 355742 [details]
Same bug report printed from FF 2.0.20 and previous versions
(Reporter)

Comment 4

10 years ago
(In reply to comment #2)
> Created an attachment (id=355741) [details]
> Example of this bug report printed from FF 3.0.5

No. That refers to hardware printer outputs - but the origin may be the same or similar - But still there should be compatibility between version upgrades of the same browser.
Component: Shell Integration → Printing: Output
Product: Firefox → Core
QA Contact: shell.integration → printing
Version: unspecified → 1.9.0 Branch
(In reply to comment #1)
> Is this bug 454532?
(In reply to comment #4)
> No. That refers to hardware printer outputs

No it doesn't -- that bug is largely about about Adobe PDF Writer, as well as other print drivers. See bug 454532 comment 3.

So, this is a duplicate -- marking as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454532
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> (In reply to comment #1)
> > Is this bug 454532?
> (In reply to comment #4)
> > No. That refers to hardware printer outputs
> 
> No it doesn't -- that bug is largely about about Adobe PDF Writer, as well as
> other print drivers. See bug 454532 comment 3.
> 
> So, this is a duplicate -- marking as such.
> 
> *** This bug has been marked as a duplicate of bug 454532 ***

That decision is a BIG MISTAKE BECAUSE NOW TTHE PROBLEM IS UNLIKLEY EVER TO BE RESOLVED!!! I AND OTHER USRS OF FIREFOX WILL BE LOOKING FOR ALTERNATIVE .

THE REAL ANSWER IS THAT ITR IS A DUPLICATE OF BUG 452289 [ALCORN - AUGUST 2008] AND THAT WAS ALSO NEVER RESOLVED.  

What is mozilla policy here . I'ld really like to know
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to comment #6)
> > *** This bug has been marked as a duplicate of bug 454532 ***
> THE REAL ANSWER IS THAT ITR IS A DUPLICATE OF BUG 452289 [ALCORN - AUGUST 2008]
> AND THAT WAS ALSO NEVER RESOLVED.  

And you'll notice that *that* bug is marked as a duplicate of bug 454532... so, my duplicate-marking was correct.

RE this being "never resolved" -- if you look at bug 454532, you'll see that Adrian Johnson (a cairo developer) has actually been doing a fair amount of analysis & investigation on this bug recently (over the last month).  So, this issue *is* getting some attention.

> That decision is a BIG MISTAKE BECAUSE NOW TTHE PROBLEM IS UNLIKLEY EVER TO BE
> RESOLVED!!! I AND OTHER USRS OF FIREFOX WILL BE LOOKING FOR ALTERNATIVE .

I understand your frustration, but having extra bugs open about the same underlying problem does *not* help -- it just creates extra noise and inhibits investigation.

Please direct further (constructive) discussion to bug 454532.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454532
You need to log in before you can comment on or make changes to this bug.