reflow wipes out TFOOT when mouse over button and TBODY style=overflow:auto

VERIFIED FIXED in M18

Status

()

Core
Layout: Tables
P4
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: KenW, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][PDTP4])

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win95; U)
BuildID:    2000072808

I have a table with the TBODY set to a fixed height and overflow:auto. In the 
table's TFOOT, I have a form with a submit button. When I pass the mouse over 
the submit button, the table is redrawn and the submit button is wiped out. 
Reloading the page fixes the display until I pass the mouse over the submit 
button again.

There seem to be many bugs with table rendering and reflows so this may be 
equivalent to one of the other ones, although I couldn't find one that seemed to 
match the above test case.

Reproducible: Always
Steps to Reproduce:
1. Load the test case (will make an attachment) in mozilla
2. Pass the mouse over the submit button

Actual Results:  Table is redrawn, wiping out submit button.			
				

Expected Results:  Table is not redrawn, submit button highlights (or not).
(Reporter)

Comment 1

18 years ago
Created attachment 12235 [details]
test case referred to in bug submission

Comment 2

18 years ago
the testcase is a real mess on my build (win95, 080108).  The table covers the
button, and the button is unclickable.

Comment 3

18 years ago
Created attachment 12526 [details]
corrected testcase (strict.dtd removed)

Comment 4

18 years ago
In order to see the reflow problem it may be necessayry to reload the testcase.
Confirming the bug
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
important reflow/layout bug.  makes the page completely unusable.  nominated for
nsbeta3
Keywords: nsbeta3

Comment 6

18 years ago
Approving for beta3: This could be related to the problem of table style 
contexts being parented incorrectly, causing reframes when you hover over links 
or buttons in a table (bug 45210).
Whiteboard: [nsbeta3+]

Comment 7

18 years ago
Marking depends on 30418: it is at least related.
Depends on: 30418
Priority: P3 → P2

Updated

18 years ago
Target Milestone: --- → M18

Comment 8

18 years ago
Tested on Win 95 with 8/31 build, the problem stated in the Summary is no longer 
happening although there is a problem. When I pass the mouse over the submit 
button, nothing happens; the submit button is NOT wiped out. However, text in 
the TBODY is overlapping the submit button.

Comment 9

18 years ago
PDT thinks this is a P4 with current bug description
Priority: P2 → P4
Whiteboard: [nsbeta3+] → [nsbeta3+][PDTP4]
(Assignee)

Comment 10

17 years ago
Fixed. This was closely related to the fix for 30418.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
Tested using 9/18 build on Windows - verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.