Sync clear out all messages from my mail server

RESOLVED INVALID

Status

Thunderbird
Migration
--
critical
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: siuws, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: version 2.0.0.19 (20081209)

I install this client and try to sync 2 accounts to this client, one for gmail and one for yahoo.  For some reason, the sync with gmail works fine, and the sync for yahoo clear out all messages from inbox when I check back from server after the sync.  Why it cannot leave the messages 'as is' just like gmail?  Is there a way to sync message back to server? Or undo, or get everything loaded back into account?  

Reproducible: Always

Steps to Reproduce:
1.download Thunderbird client and install
2.setup a new account with yahoo.com
3.messages deleted from server after they are downloaded to client
Actual Results:  
since everything was deleted, including messages I need to keep in server.  I will warn everyone I know to consider to use this client.

Expected Results:  
It should work just like download with gmail, leave everything AS IS!

This is a question report at chat, was push back to Yahoo, then Yahoo said waht was deleted is deleted (push back to Thunderbird)!
Which protocol is used in both cases ?
Did you used pop3 for yahoo and imap in the gmail case ?

Comment 2

9 years ago
If POP is being used on the Yahoo account, the thunderbird settings for yahoo account should be set to "Leave messages on server" - not sure what the default is currently, but I seem to remember that the default is NOT to leave msgs on server.

There is a debate raging in another bug report about the correct default setting with good points on both sides of this issue.
The default is to delete the mails on the server with pop3. Using "leave messages on the server" with pop3 is a bad replacement for a real Imapo server.
pop default settings - bug 231541
(Reporter)

Comment 5

9 years ago
Yes, default  from the version I have is NOT leave the message on server.  Before you can have a result on the debate of which way it should be, is there a way to reload or export/import or recover the messages back to yahoo server's inbox?  I can't have the data in this local client for too long, which I need to sync things back to yahoo server or at least export to a client at some other machine...

thanks
Bugzilla is not for support and we can't do anything if you don't answer the questions (comment #1) but i'm sure that this no bug and just a misunderstanding about pop3.

Using pop3 usually means that the client downloads and deletes the message from the server because pop3 is not designed to use it like imap or webmail.
It works in many cases with modern pop3 server implementations but not with all servers. The pop3 server from my ISP is an example (UIDL is changing)
(if you are interested about pop3: http://en.wikipedia.org/wiki/Pop3 )

If you want to work with emails on a central server you should use a server that supports imap.

There is no way to upload the messages back on a pop3 server.
What you can do is to create or use an existing gmail Account, enable the imap support in gmail settings, create the Account in Thunderbird as IMAP Account and drag&drop the downloaded message to the Imap server.
(read http://mail.google.com/support/bin/answer.py?hl=en&answer=75725)
You could upload the mails only if Yahoo would offer a IMAP server but they offer it AFAIK only if you pay for it.

Btw: If a client like Thunderbird deletes a message in gmail the message is still visible in gmails webinterface. I think they added this as workaround for many inexperienced users which flooded their support.

Marking this bug as invalid, see comment #4 which may change the default behavior.
Please use http://www.mozilla.org/support/thunderbird/ instead of bugzilla if you have additional support related questions, thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.