If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow comments to be viewed in all groups

REOPENED
Unassigned

Status

Websites Graveyard
spreadfirefox.com
REOPENED
9 years ago
6 years ago

People

(Reporter: abuchanan, Unassigned)

Tracking

(Depends on: 1 bug)

unspecified

Details

(Reporter)

Description

9 years ago
Mary, I have this as a P1 from 
https://wiki.mozilla.org/SFx_homepage_requirements#Groups

but I can't remember the problem.  Could you describe it please?

Comment 1

9 years ago
Hey there:  As a normal user I couldn't view comments that people make in different groups unless I am a member of that group.  I would get "Access Denied".  But it now seems to be working.  Did anyone change this?

Comment 2

9 years ago
I have not changed anything. 
Please let me know if you need me to look into this.

Can we use the below wiki pages to document how the site is configured and how it operates ..
https://wiki.mozilla.org/Spreadfirefox_site_operation
https://wiki.mozilla.org/Spreadfirefox_site_configuration

Updated

9 years ago
Target Milestone: --- → 3.0
(Reporter)

Comment 3

9 years ago
Is this working, can I mark this as WORKSFORME?

Comment 4

9 years ago
Hey there: I have been playing around and most comments are visible.  Three groups would not allow me to view comments without joining --
Fire Fox in Kannada
IES La Malladeta
Revere High School Firefox Committee
AB Designs Inc Project Group (invite-only)

So not sure if they have different permissions (AB Designs def. does) or what.

Comment 5

9 years ago
Should the visibility all comments be determined by the group visibility ?

Comment 6

9 years ago
Hey Paul:  I am not sure what you mean by the group visibility.  Please clarify :)

Comment 7

9 years ago
Hi Mary,

Sorry for the confusion what i was trying to say was should the visibility of all comments in a group context be determined by whether the group is public / private. It looks as though from your comment in #4 that most groups are public as most comments are visible to authenticated users regardless of group membership.

I'll take this bug and have a look to see if everything is ok

-Paul
Assignee: nobody → paul

Comment 8

9 years ago
(In reply to comment #4)
> Hey there: I have been playing around and most comments are visible.  Three
> groups would not allow me to view comments without joining --
> Fire Fox in Kannada
> IES La Malladeta
> Revere High School Firefox Committee
> AB Designs Inc Project Group (invite-only)
> 
> So not sure if they have different permissions (AB Designs def. does) or what.

It looks as though "Organic groups access control"  has been disabled at some point which gives you the default behaviour of all created groups now being public. I am thinking that the ones that are private are relics from the time before the private to public changeover. 
Would we want to convert these group to be public ?

Comment 9

9 years ago
Resolving this bug as fixed. 

Please let me know if you need any further assistance.

Best, Paul
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 10

9 years ago
I created a new invite-only project.Comments in this project are still not visible to non-members.

SO reopening this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 11

9 years ago
I have a couple thoughts on this bug, as it seems like a confusing one.

Having a group be private is an explicit option on the project creation page...

"[checkbox]  Private project - Should this project be visible only to its members? Disabled if the project is set to List in Directory or Membership requests: open."

So, the whole idea is that the comments are private for these projects, i.e. that's what the owners are expecting.  We're about to turn that off and violate what users are expecting.  Or are we just doing this for invite-only groups?  Or both?  Do we know for sure?  :)

My thinking is that the root cause here is that we allow private groups at all.  That doesn't seem very "community" to me, maybe I'm missing a point, but why would anyone ever need a private group on SFx?  And if they need a private group, is SFx really the place for them?

Also, this isn't specifically related to the redesign, as the issue exists on production (pre sfx v3) currently.  So, a couple questions...

1)  Do you think it's worth exploring the idea of dropping private groups altogether?

2)  Is this blocking 3.0, or can we move this to 3.1 if needed?

Just wanted to write that down before I forgot, Thanks!

Comment 12

9 years ago
Hey there:  As long as private comments aren't popping up in recent discussions, I'm ok pushing this discussion to post-redesign.
This was actually something I was going to bring up as well. While we might want to give project leaders some membership control, I don't see the point in invite only projects.  

Even if the project is being carried out by a specific team, but they're doing it in the open for others' benefit, I don't think it hurts to let others join the project. And maybe in that case it works, but I definitely agree that private should be removed.

Comment 14

9 years ago
Moving to 3.1. If we go this route there will need to be some communication to current private group owners.  Too much to deal with now :)
Target Milestone: 3.0 → 3.1

Comment 15

9 years ago
Catching up, but i think we need this module ...
http://drupal.org/project/comment_og
Depends on: 484497

Updated

8 years ago
Assignee: paulbooker → nobody
(Assignee)

Updated

6 years ago
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.