Add-On Manager shows "Restart SeaMonkey to complete your changes" without any change

RESOLVED FIXED in seamonkey2.0a3

Status

SeaMonkey
Build Config
--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Tobias Fischer, Assigned: standard8)

Tracking

({regression})

Trunk
seamonkey2.0a3
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090107 Mnenhy/0.7.5.20005 SeaMonkey/2.0a3pre
Build ID: 20090107100757

Everey time when open the Add-On-Manager in SeaMonkey it shows the Information-Message: "Restart SeaMonkey to complete your changes", even when there are no changes. 

Also it seems, that it was not possible to deinstall Add-Ons properly.

Last working Build was Windows Tinderbox-Build ID: 20090107092922
First bad is Tinderbox Build ID: 20090107100757.

In this regression-range there were only the checkin for Bug 469835, so this must have caused the regression.
(Assignee)

Comment 1

9 years ago
I very much doubt anything in bug 469835 would have caused this problem - especially as it shouldn't have affected any SeaMonkey.

Can you do about:buildconfig on those two pages and let us know what the mozilla-1.9.1 build revisions are?
(Reporter)

Comment 2

9 years ago
The mozilla-1.9.1 build revisions for both Tinderbox-Builds are the same: http://hg.mozilla.org/releases/mozilla-1.9.1/rev/e3f8301acef5

Only the comm-central build revisions are different:
Build 20090107092922
http://hg.mozilla.org/comm-central/rev/9b6855526bb6

and Build 20090107100757
http://hg.mozilla.org/comm-central/rev/9f801d1c8b30

I am wondering too, that the Patch from Bug 469835 will cause this, but I can't find any other Checkin in this Range. Hmm.
(Assignee)

Comment 3

9 years ago
There's a couple of options I can think of:

1) The patch caused rebuilding of the dep build in such a way that because its a dep build something is now showing up as broken when it was "missed" before.
2) The dep build hasn't rebuilt in the right manner and hence caused a problem.

Can you try the nightly build or is that how you found this in the first place?

Comment 4

9 years ago
And going back to the older build fixes the issue again?
I wonder if your comment about unsuccessfully deinstalling has anything to do with that - I personally am not seeing any new problem.
(Reporter)

Comment 5

9 years ago
I hav first seen this issue with todays Windows-Nightly-Build 2009010800, and have tested with the Tinderbox-Builds to get an proper regression-range. 

And yes, going back to the Build 20090107092922 or earlier will resolve this issue. 

Deinstall todays enigmail Nightly-Build has not worked, but  am now on an different Machine, and can't took a better look. 

Also Enigmail will not work for me in SeaMonkey, see:
https://www.mozdev.org/bugs/show_bug.cgi?id=18886

Maybe the inproper Enigmail instllation will do ome strange things. 

Now on Mac, I do not see the regression in AMO (will switch to win soon and test more)

Comment 6

9 years ago
Mark, looking at the bug 469835 checkin, did you make sure the THUNDERBIRD_VERSION from configure.in isn't used anywhere in the SeaMonkey build (including ChatZilla, venkman, and DOMi)? I have seen similar behavior to what Tobias is seeing back when I investigated Lightning stuff and it ended up with empty min/maxVersion fields for any application...
(Reporter)

Comment 7

9 years ago
Hmm, while testing Windows via Botcamp on Mac, i can't reproduce the strange AMO behaviour. Anyway, I have to go now for the next few days, can't do anything allmost until sunday.

Btw., while testing the strange Builds, there are no errors in error-console.
I had the same problem with yesterdays (01/07) build and an NoScript-Update (1.8.8.5 from 1.8.7.6). After deinstalling NoScript and installing it again, the error was gone. With todays build (Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b3pre) Gecko/20090108 SeaMonkey/2.0a3pre) the update to NoScript 1.8.8.8 worked without an problem.
OS: Windows XP → All
(Assignee)

Comment 9

9 years ago
(In reply to comment #6)
> Mark, looking at the bug 469835 checkin, did you make sure the
> THUNDERBIRD_VERSION from configure.in isn't used anywhere in the SeaMonkey
> build (including ChatZilla, venkman, and DOMi)? I have seen similar behavior to
> what Tobias is seeing back when I investigated Lightning stuff and it ended up
> with empty min/maxVersion fields for any application...

Yes I did. http://mxr.mozilla.org/comm-central/search?string=THUNDERBIRD_VERSION

In any case, Chatzilla and Venkman don't work with Thunderbird, and DOMI has hard-coded values.
(Reporter)

Comment 10

9 years ago
Created attachment 356429 [details]
AMO and Error-Console Screenshot

I still got this Problem with the 2009011100-Nightly-Build, so I have tried to investigate a little more. 

If I open the AMO after starting SeaMonkey, the Infobox "Restart..." suddenly appears, without any (Un-) Installation of Add-Ons. If I close the Infobox clicking the Button at right, it appaers again when I change the view (go to Themes or other Tabs). 

Uninstall or disable an Add-On will not work for me properly. I have tried to uninstall the latest Flashblock-Build, but after restart SeaMonkey from AMO Flashblock was still listed, only the Flashblock-Icon was gone. 

And now there are some Messages in Error-Console, four times:

"No chrome package registered for chrome://flashblock/content/flashblock-32.png"

and when clicking the Flashblock "Options" Button:
"No chrome package registered for chrome://flashblock/content/options.xul"

After clicking the "Options" Button, AMO will not take any Input anymore, clicking on the AMO Window will bring only the Systems Failure Sound, even clicking an Button or just somewhere else in the Window. Also I can't close the AMO, when try to exit SeaMonkey AMO Window stays open and the seamonkey.exe Process is still running. 

I got this Bug too running SeaMonkey on my Win2k-VirtualBox Testsystem. Also I have tested with an different Profile without any additional Add-Ons, and while uninstall all additional Add-Ons using the 2009010700-Nightly, and than running the 2009011100-Nightly again, but the AMO-Problem still exist.

If someone can give me some advice for better investigation, i will do so.
Confirming Restart prompt with Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9.1b3pre) Gecko/20090111 SeaMonkey/2.0a3pre

with this message in Error Console:
No chrome package registered for chrome://chatzilla/skin/images/logo.png

and ChatZilla not working:
- missing icon in Components Bar;
- enabled in Addons Manager, with no icon through
- no response after clicking on Settings button, system failure sound is played
- need to kill SeaMonkey to get Addons Manager closed

definetely a bad regression
(Reporter)

Comment 12

9 years ago
To bad. I have tried to investigate a little more using regmon while running SeaMonkey, and the Problem is gone on my default System. Sad to say, that I don't know what I have done for this. 

Using RegMon I noticed, that there was no Key:
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\seamonkey.exe
in the Registry (I am using the Zip-Builds, never used an Installer-Build on this System), so I have added this Key and the Path.

Also I have tried to install and uninstall Enigmail while running RegMon, but I am not sure, if I have done anything else while try to investigate. 

On the VirtualBox Test-System I still get this Error, even after Uninstall and reinstall all additional Add-Ons, and add the App Path to the Registry. Now I don't know what to do next, to get better information about the Problem.

Comment 13

9 years ago
You could see if |grep -in 'Version=""' /path/to/your/profile/extensions.rdf| brings up anything. I once had a similar problem when I caused this (empty min/maxVersion) to happen for some extension (was a bug in a patch of mine back then).
(Reporter)

Comment 14

9 years ago
Created attachment 356738 [details]
extensions.log-File from Profile with AMO Error

In my affected User-Profiles I have found an "extensions.log" File wich contains an Error-Message. This File was first created 2009-01-08 11:43 UTC-002, while starting the 2009-01-08 Nightly-Build the first time. I will attach a smaller file from an Test-Profile, wich is smaller, but contains the same Error.
(Reporter)

Updated

9 years ago
Attachment #356738 - Attachment description: extensions.lod-File from Profile with AMO Error → extensions.log-File from Profile with AMO Error

Updated

9 years ago
Attachment #356738 - Attachment mime type: application/octet-stream → text/plain
(Reporter)

Comment 15

9 years ago
Thanks to KaiRo for his hint, that an empty minVersion/maxVersion String will cause Issues like this. 

After a closer look into AMO I have noticed, that "Palm Sync" has got the Info-Message "This add-on will be installed when SeaMonkey is restarted". 

In the extensions.cache there was the line:
app-global	p@m	rel%p@m	1232085170	needs-install

and in p@m-extensions install.rdf Thunderbirds Version-Strings are empty:

    <em:targetApplication>
      <!-- Thunderbird -->
      <Description>
        <em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
        <em:minVersion></em:minVersion>
        <em:maxVersion></em:maxVersion>
      </Description>
    </em:targetApplication>

Edit the install.rdf and add TBs min/maxVersion-Strings will fix this Issue and Palm Sync was installed without Problems at restart.
(Assignee)

Comment 16

9 years ago
Ok, I see why this happens now, not sure how I missed it. I'll come up with a patch in a while.
Assignee: build-config → bugzilla
(Assignee)

Comment 17

9 years ago
Created attachment 357335 [details] [diff] [review]
The fix

Fix the generation of versions. I'm treating this patch as build config btw.

This makes us get the THUNDERBIRD_VERSION from the appropriate version.txt file.

Note I've added in SEAMONKEY_VERSION as well because Robert's said before that we should be moving the obtaining of the version to outside configure.in.

Not tested (copy/pasted from calendar though), but this should fix the problem.
Attachment #357335 - Flags: review?(kairo)

Comment 18

9 years ago
Comment on attachment 357335 [details] [diff] [review]
The fix

r=me by code inspection, thanks for finding this!
Attachment #357335 - Flags: review?(kairo) → review+

Updated

9 years ago
OS: All → Windows XP
(Assignee)

Comment 19

9 years ago
Patch checked in: http://hg.mozilla.org/comm-central/rev/e8bae7d46367
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0a3
You need to log in before you can comment on or make changes to this bug.