AJAX Bug and Loss of HTML Data

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: filip.misovski, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

A public web site is built using an AJAX toolkit and a dashboard application. The application works perfectly fine on IE, but it breaks in Firefox. It loads without an error without all resources (and nothing is in the error log nor with Firebug anything can be detected). The end-result is a partial working site, meaning one can see the overall navigation structure but without all the XHTML content inside the tabs and widgets. It's an extremely strange behavior, since one cannot find an error with the applications or the JS code. Pls let me know if you have any idea why this behavior happens in Firefox under the circumstances listed above. Try the URL above both on Firefox and IE to see the difference, even though no errors occur in Firefox.

Thanks and best regards! Filip 

Reproducible: Always

Steps to Reproduce:
1. Just load the URL http://sapfarm.com with clean browser cache
2. As you refresh the same application, sometimes starts loading rest of the content but not always
3. In general, the application loads without the whole XHTML and sometimes loads only loads the first or first two widgets on the page (the rest come empty).
Actual Results:  
Partial XHTML content rendered, while all resources seem to be loaded from the server.  The client rendering screws up somewhere, and stops processing the entire content.

Expected Results:  
The expected result is rendering of the entire content of the application as seen in Internet Explorer.

If there's any need to share the entire application and code, pls ping me on my email address.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
I see some tabs missing on the right (under Top Events). Would be nice to have a minimized testcase. Have you tried this on a latest-nightly build (or at least a 3.1 beta 3pre build)?

ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-1.9.1/ - for the latest 3.1 build.

ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/ - for the latest trunk build.
Keywords: testcase-wanted
(Reporter)

Comment 2

10 years ago
I cannot isolate a better test case, because anyhow this problem occurs due to large amount of XML/XHTML processing that happens in this application.  As you saw, there's some content appearing like the Flash and Career Highlights, but Top Events or the other tabs of this application is all empty (compared to IE, where all the content is rendered properly).

Can you pls run some diagnosis / power debugging on why such cut-off on the XHTML content happens in this application without displaying any error message from the code?

Thank you very much!  Filip
Version: unspecified → 3.0 Branch
This is definitely a networking bug, some times I get the content, some times I don't. It's also still buggy on trunk. Reducing severity, critical is generally used for crashes and the sort. This page shows up fine in Chrome and IE, not sure what the problem is though.

Again, the smallest possible testcase that reproduces this bug would greatly help in debugging this issue.
Severity: critical → major
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Version: 3.0 Branch → Trunk
Try simply removing chunks of the page at a shot, then seeing how small it can get without causing this bug see https://developer.mozilla.org/en/Reducing_testcases . I would have guessed this was a param bug, similar to bug 364188, but it's still broken on trunk.
sapfarm.com works for me on trunk no matter how many times I reload. Filip, can you still reproduce?
Whiteboard: [closeme 2-26-12]

Comment 6

7 years ago
Closed per Whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2-26-12]
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.