bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Snowl can't subscribe to feeds which require authentication cookies

RESOLVED WONTFIX

Status

Mozilla Labs
Snowl
P2
major
RESOLVED WONTFIX
10 years ago
6 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

unspecified
x86
All

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5 Ubiquity/0.1.4
Build Identifier: 0.2

When attempting to subscribe to a feed that requires cookies (for example, a Google Reader feed), the subscription dialog reaches the "Connected" status and then stops.  This apparently happens because Snowl does not send any cookies with its request, and the server returns an error message instead of a valid feed.

Example feed: http://www.google.com/reader/atom/user%2F10529074966557486466%2Fstate%2Fcom.google%2Freading-list

Ideally, Snowl could use the browser's cookies and load the feed.  Or if that's not possible, it should display a useful error message when given an invalid or empty feed.

Reproducible: Always
I see the same thing.  It's strange, though, as Snowl uses XMLHttpRequest to load the feed, and XMLHttpRequest is supposed to send cookies.  So there might be a different bug at work here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Snowl throws the following exception when it tries to subscribe to a Google Reader feed:

2009-01-09 13:34:33	Snowl.Feed null	ERROR	error on subscribe result: TypeError: this.humanURI is null
Severity: normal → major
OS: Linux → All
Priority: -- → P2
Target Milestone: -- → 0.3
Resolving Snowl bugs WONTFIX because it is no longer an active Labs experiment.
Assignee: myk → nobody
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.