Closed Bug 472761 Opened 11 years ago Closed 11 years ago

TM: testDoubleComparison in trace-tests.js fails

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: gal, Assigned: gal)

Details

(Keywords: verified1.9.1, Whiteboard: fixed-in-tracemonkey)

Attachments

(1 file, 1 obsolete file)

testDoubleComparison : FAILED: expected string ( "finished" )  [sideExitIntoInterpreter: 1]  != actual string ( "finished" )  [sideExitIntoInterpreter: 2]

If someone can bisect that would be great, otherwise I will grab the bug and do it later today.
This looks like something related to the timeout stuff we added, still investigating. It passes by itself, and it also passes in the larger file if I decrease the loop count below 500k.
Assignee: general → gal
gal, i couldn't reproduce this error.
Attached patch track timeout exits separately (obsolete) — Splinter Review
Its timeout dependent. Your machine might be too fast and the timeout doesn't happen. Try increasing the loop counter in that test case.
Attachment #356268 - Flags: review?(jwalden+bmo)
Attachment #356268 - Attachment is obsolete: true
Attachment #356272 - Flags: review?(jwalden+bmo)
Attachment #356268 - Flags: review?(jwalden+bmo)
Comment on attachment 356272 [details] [diff] [review]
v2, condition on JS_JIT_SPEW not DEBUG, tested with debug and opt

I don't think the #ifdef JS_JIT_SPEW is necessary (it's built into how AUDIT is defined), nor does it substantially increase code clarity, but whatever.
Attachment #356272 - Flags: review?(jwalden+bmo) → review+
Whiteboard: fixed-in-tracemonkey
Summary: TM: testDoubleComparison in trace-tests.js failes → TM: testDoubleComparison in trace-tests.js fails
http://hg.mozilla.org/mozilla-central/rev/d3a4e58a54f5
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
already in js1_8_1/trace/trace-test.js
Flags: in-testsuite+
Flags: in-litmus-
v 1.9.1, 1.9.2
should have v trunk at the same time. v 1.9.3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.