Last Comment Bug 47278 - Embedding apps can't setCurrentHistoryIndex
: Embedding apps can't setCurrentHistoryIndex
Status: VERIFIED INVALID
: embed
Product: Core
Classification: Components
Component: Embedding: APIs (show other bugs)
: Trunk
: All All
: P3 normal (vote)
: ---
Assigned To: Radha on family leave (not reading bugmail)
: David Epstein
: Myk Melez [:myk] [@mykmelez]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-02 01:35 PDT by Alexei V. Mokeev
Modified: 2001-09-10 00:22 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alexei V. Mokeev 2000-08-02 01:35:49 PDT
Method setCurrentHistoryIndex of History interface 
must throw Unimplemented exception.
Since merging Webclient and Mozilla M16 this method doesn't work.
And now this method must be implemented by another way or throw Unimplemented
exception.

Reproduced with Mozilla M16 and Webclient sources from July,31.
Comment 1 edburns 2000-08-04 11:08:28 PDT
I accept.
Comment 2 edburns 2000-08-04 16:19:17 PDT
Changed summary.  Old title: setCurrentHistoryIndex must throw Unimplented
exceptiontCurrentHistoryIndex must throw Unimplented exception.

As far as I can tell, embedding apps can't setCurrentHistoryIndex, since the
only method that provides such functionality is in nsIBrowserInstance, which
doesn't appear to get created in the embedded context.
Comment 3 Judson Valeski 2000-08-08 10:46:23 PDT
session history is going to be redone. cc'ing potts
Comment 4 Judson Valeski 2000-12-15 14:19:45 PST
-> radha
Comment 5 Paul Wyskoczka 2001-01-10 09:38:20 PST
Updating QA Contact
Comment 6 Radha on family leave (not reading bugmail) 2001-02-16 16:42:23 PST
SH has undergone several changes since this bug was filed. please see 
xpfe/components/shistory/public/nsISHistory and nsIHistoryListener for the 
latest. Also note that nsIHistoryListener will go thro'  more changes to meet 
the needs of embedding.
Comment 7 Michael Dunn 2001-04-18 10:23:33 PDT
Correction: Changing QA contact for the Embed API bugs to David Epstein.
Comment 8 David Epstein 2001-04-30 17:53:43 PDT
verified.

Note You need to log in before you can comment on or make changes to this bug.