Closed Bug 472794 Opened 11 years ago Closed 11 years ago

Crash [@ XPCWrappedNative::GetIdentityObject] with XPCNativeWrapper.prototype

Categories

(Core :: XPConnect, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: moz_bug_r_a4, Assigned: mrbkap)

References

Details

(Keywords: verified1.9.1)

Attachments

(2 files)

Attached patch FixSplinter Review
Easy fix.
Assignee: nobody → mrbkap
Status: NEW → ASSIGNED
Attachment #356281 - Flags: superreview?(jst)
Attachment #356281 - Flags: review?(jorendorff)
Attachment #356281 - Flags: superreview?(jst)
Attachment #356281 - Flags: superreview+
Attachment #356281 - Flags: review?(jorendorff)
Attachment #356281 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/d1c518aec998
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Attachment #356281 - Flags: approval1.9.1?
Comment on attachment 356281 [details] [diff] [review]
Fix

Pretty easy null-defense patch.
Attachment #356281 - Flags: approval1.9.1? → approval1.9.1+
No revision because of merging pain and the checkin for bug 472674.
Keywords: fixed1.9.1
Duplicate of this bug: 466583
Verified fixed on the 1.9.1 branch using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090518 Shiretoko/3.5b5pre. I used the testcase in the bug to verify.
You need to log in before you can comment on or make changes to this bug.