When more then 1 firefox window is opened and then 1 is closed no option for saving tabs.

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: ropelive, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-12-01])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

When more then one firefox window is open (including the window which shows all previous downloaded content), and you then proceed to closing one of the opened windows, no option is given for saving the session of the particular window.

Happens in: 
1. Windows Xp
2. Windows Vista

Reproducible: Always

Steps to Reproduce:
1. Open 2 or more windows for firefox.
2. Open 2 or more tabs within those windows.
3. Close one of those windows.
4. No option to save the opened tabs of that window.
Actual Results:  
Options given:
1. Close tabs
2. Cancel

Expected Results:  
Options given:
1. Save and close tabs.
2. Close tabs
3. Cancel

Though I'm not sure if this is actually a bug or an intentional decision. I thought I'd report it anyway. That's because I thought it could be thought of as annoying by users and also because it could be a nice axtra feature.
I'm pretty sure this is by design:

1) Your session is still open, as you have tabs still opened in another window.
2) When would firefox restore it, next time you open a new window?

This is related to, but not exactly the same as bug 354894. Note: you can achieve a similar effect (but this will close and save _both_ windows) by using File->Exit.
OS: Windows XP → All
Hardware: x86 → All

Updated

10 years ago
Component: Session Restore → General
QA Contact: session.restore → general
Whiteboard: DUPEME

Comment 2

10 years ago
Starting with Firefox 3.5, you can restore closed windows and all of the tabs within so I propose WONTFIX here.
Whiteboard: DUPEME → DUPEME, [wontfix?]
Reporter, please retest with Firefox 3.6.12 or later in a fresh profile (http://support.mozilla.com/kb/Managing+profiles). Also update your plugins (flash, adobe reader, java, quicktime, silverlight, etc.) Go to the developer's website and download the latest version from there. If you no longer see this issue, please close this bug as RESOLVED, WORKSFORME. If you do see the bug, please post a comment.
Whiteboard: DUPEME, [wontfix?] → [CLOSEME 2010-12-01]
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Updated

8 years ago
Resolution: INCOMPLETE → WORKSFORME
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new
> profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to
> see this issue with the newest firefox and a new profile, then please comment
> on this bug.

Great it works:)!
You need to log in before you can comment on or make changes to this bug.