test_bug458898.html still creates invisible windows on SeaMonkey

VERIFIED DUPLICATE of bug 471959

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 471959
9 years ago
9 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
The test introduced by bug 458898 fails with SeaMonkey, creating invisible windows. We papered over this in bug 469331 by marking it todo() and hoped bug 465993 or bug 469203 would fix it.
The latter has landed on both trunk and 1.9.1 now and had no influence on the SeaMonkey problem, and I just tested the fix for the former and also couldn't see any change there, so something else is still wrong here.
Flags: blocking1.9.1?
(Reporter)

Comment 1

9 years ago
Current Tinderbox output:

Linux:
*** 42442 INFO TEST-KNOWN-FAIL | /tests/layout/base/tests/test_bug458898.html | innerWidth: 1 >= 100 ?
*** 42443 INFO TEST-KNOWN-FAIL | /tests/layout/base/tests/test_bug458898.html | innerHeight: 1 >= 200 ?

Mac:
*** 42447 INFO TEST-KNOWN-FAIL | /tests/layout/base/tests/test_bug458898.html | innerWidth: 0 >= 100 ?
*** 42448 INFO TEST-KNOWN-FAIL | /tests/layout/base/tests/test_bug458898.html | innerHeight: 0 >= 200 ?

Windows:
*** 42360 INFO TEST-PASS | /tests/layout/base/tests/test_bug458898.html | innerWidth: 104 >= 100 ?
*** 42361 INFO TEST-KNOWN-FAIL | /tests/layout/base/tests/test_bug458898.html | innerHeight: 0 >= 200 ?


I can confirm the Linux numbers with my local trunk build including attachment 356223 [details] [diff] [review] from bug 465993.
I'm not sure what this bug is about:
comment 0 seems to refer to your bug 469331 comment 2;
comment 1 seems to refer to my bug 471959;

and, at least on my local Windows 2000 _trunk_ build, the two are different:
I get the 0 innerHeight value, but the window is there.
(Reporter)

Comment 3

9 years ago
OK, you filed a bug on the failure of that test and didn't even comment about that in the original bug? In that case, look for a fix yourself and feel free to dupe this to yours. Bye.
(In reply to comment #3)
> OK, you filed a bug on the failure of that test and didn't even comment about
> that in the original bug?

First, I commented in bug 469331 and your complained I didn't open a separate bug yet;
I did later and now you complain I did not continue to comment in bug 469331;
I'm sorry but I have a hard time trying to understand what you want.
Besides, there is the dependency and you cc'ed yourself to that new bug...

> In that case, look for a fix yourself and feel free to dupe this to yours. Bye.

What's wrong with you ?
In bug 469331, I asked you a question, you complained and did not answer;
and now, the same is happening here :-(
(In reply to comment #4)
> First, I commented in bug 469331 and your complained I didn't open a separate
> bug yet;
> I did later and now you complain I did not continue to comment in bug 469331;

When you split something off into a separate bug you should comment in the first bug (in a comment that generally fits in one line of text) so people know that the separate bug has been filed and can find it.
(Reporter)

Comment 6

9 years ago
right. I made myself all the work of investigating that it still happens with the new patches and determine what the boxes report and then filed this bug just to find out you already filed it as bug 471959 without probably anyone except yourself knowing about that.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471959
(In reply to comment #5)

I usually do !
In this case, it looks like I either thought my bug 469331 comment 22 was
enough (...) or forgot to add a new comment :-|

(In reply to comment #6)
> just to find out you already filed it as bug 471959 without probably anyone

I know the feeling and I'm sorry for you,

> except yourself knowing about that.

but, as I wrote in comment 4, I can't understand how *you* can say that:
{
https://bugzilla.mozilla.org/show_activity.cgi?id=471959

kairo@kairo.at  	2009-01-03 04:54:40 PST  	 CC  	  	kairo@kairo.at
}

> *** This bug has been marked as a duplicate of bug 471959 ***

And, with all that, you're still not explicitly answering my question:
it seems you/Linux+191 and I/Windows+trunk are reproducing a different behavior, not getting or getting the actual (visible) window ... which may or may not be different bugs.
(Reporter)

Comment 8

9 years ago
(In reply to comment #7)
> And, with all that, you're still not explicitly answering my question:
> it seems you/Linux+191 and I/Windows+trunk are reproducing a different
> behavior, not getting or getting the actual (visible) window ... which may or
> may not be different bugs.

I only looked at what tests report and didn't try explicit calling commands myself. And now I also won't do that any more because I'm enough pissed off already by this stuff to want to forget it as fast as possible.
Flags: blocking1.9.1?
(In reply to comment #8)
> I only looked at what tests report and didn't try explicit calling commands

Well, you also tested that bug 465993 (current) patch (will) makes no difference for you :->

> myself. And now I also won't do that any more because I'm enough pissed off
> already by this stuff to want to forget it as fast as possible.

Too bad, because this is really the one thing I'm interested in since I asked you in bug 469331 :-(

V.Duplicate then.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.