Mail View window Character Coding menu shows the Mail composer set in the Customize dialog

VERIFIED FIXED

Status

MailNews Core
Internationalization
P2
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: cata)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nsbeta3+)

(Reporter)

Description

18 years ago
** Observed with 8/1/2000 Win32 M17 build **

Currently, we are supposed to share the static/cutomized list
among Browser, Mail, and Editor. We seem to be but there is 
one confusing fact.

To see this problem, do this:

1. Create a new profile with a US build.
2. Start and open the Browser window. Check to see that
   Western (ISO-8859-1) is in the static list.
3. Now add one item like Cyrillic or whatever via the 
   Customize dialog.
4. Re-start and check that the new addition shows in
   the Browser menu. Check also the Editor and Mail menus.
   Both sshould also show the same static list.

5. Open also the Customize dialog for Browser and Editor and
   confirm that the custom choices on the right pane show 
   exactly the same set on both Windows.
6. Now look at the Customize dialog in the Mail window.
   Here you don't see the same set. 
7. Open the Mail Compose window and check the Customize
   chosen list. You see that Mail window shares this set instead.

The problem is that the Mail window actually is showing the Customize
list items from Browser and Editor in the menu but the Customize
set you find is from the Mail composer instead!
Confused? Most users would be with this problem.
(Reporter)

Comment 1

18 years ago
Nominating for nsbeta3.
We have been spending a lot of time to create consistent
UI for charset menu. This is prety bad for that.
Keywords: nsbeta3

Comment 2

18 years ago
Adding Jennifer to cc: list.

Comment 3

18 years ago
Reassign charset menu related bug to cata.
Assignee: nhotta → cata

Comment 4

18 years ago
reassign to ftang
Assignee: cata → ftang

Comment 5

18 years ago
mark as assign
Status: NEW → ASSIGNED

Comment 6

18 years ago
nsbeta3+ per bug meeting. Mark it P2. Cata, is this one of the thing you want to 
fix this week ? Will this fixed by 39793?
Assignee: ftang → cata
Status: ASSIGNED → NEW
Priority: P3 → P2
Whiteboard: nsbeta3+
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

18 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

18 years ago
** Checked with 9/11/2000 Win32 build **

Now I see the items from the Browser/Editor Customize list
on the Mail Customize list as well. 
The Composer list has its own set.
This is the desired result.
Marking the fix verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.