All users were logged out of Bugzilla on October 13th, 2018

CSS: Priority of a:link over specified class=

VERIFIED INVALID

Status

()

P3
minor
VERIFIED INVALID
19 years ago
10 years ago

People

(Reporter: mike, Assigned: pierre)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test3 i686; en-US; m18) Gecko/20000801
BuildID:    2000080113

Mozilla seems to prefer style definitions from a:link
over ones specified in class=
Not sure if this is a bug or a feature.

Reproducible: Always
Steps to Reproduce:
1. create a style definition for a:link and a.xyz
2. <a href="..." class="xyz" ... >
3. mozilla preferes a:link over a.xyz definitions to render the link

Expected Results:  Good question.
At least other browsers seem to priorize a.xyz over a:link.

Comment 1

19 years ago
Confiriming, changing OS/Plat to all in hopes someone who knows the exact css
specs knows which should hold precedence.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Need a testcase.

Sounds like an INVALID bug, since it should depend on order (pseudo-classes and
normal classes have the same specificity).

Comment 3

18 years ago
Created attachment 13074 [details]
Testcase: showing correct cascade for A:link vs. a.classname

Comment 4

18 years ago
Marking INVALID: testcase shows that Mozill ais cascading correctly.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

18 years ago
Thanks for the clarification. As said initially it was not clear
to me what the correct behaviour is. I just noticed that NS and IE
did display it differently.

Comment 6

18 years ago
Adding 'verifyme' keyword
Keywords: verifyme
(Reporter)

Comment 7

18 years ago
To clarify the difference, i added a test case
which behaves differently between NS and Mozilla.
(Reporter)

Comment 8

18 years ago
Created attachment 13132 [details]
Demonstrates different behaviour between NS and Mozilla
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
VERIFIED
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.