Multiple passwords on one page overwrite without prompting

RESOLVED FIXED

Status

()

Toolkit
Password Manager
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Clarence Risher, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Given a page with two password inputs, after saving a password for one of them any future logins with both of them overwrite the first password with the second, and the second is filled into the first box.

Reproducible: Always

Steps to Reproduce:
1. Visit a page with two un-differentiated password fields
2. Log in with just the first field, save the password when prompted
3. Log in again with both fields
Actual Results:  
No password save prompt, second password automatically overwrites saved first password.

Expected Results:  
Prompt to save second password, or no prompt and no save.  Definitely not overwriting without prompting.
Component: General → Password Manager
Product: Firefox → Toolkit
QA Contact: general → password.manager
Version: unspecified → 1.9.0 Branch
The password manager only supports saving 1 password for a login, so if the end  goal here is to have it fill both fields with different values, then this is a dupe of bug 222589 (WONTFIX).

The other two symtoms you describe are already fixed, and will be in Firefox 3.1 - bug 394611 and bug 327977. [You should update your browser anyway, Firefox 3.0.1 is old.]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.