Mozmill tests run mostly forever and don't stop

RESOLVED INCOMPLETE

Status

--
blocker
RESOLVED INCOMPLETE
10 years ago
2 years ago

People

(Reporter: gkw, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
I tried running both the scripts from https://bugzilla.mozilla.org/show_bug.cgi?id=471510#c0 and https://bugzilla.mozilla.org/show_bug.cgi?id=471510#c5 but nothing shows up in the output, the test doesn't run, and Mozmill seemingly hangs at "Running Test..." This occurs both using Run Test File and also when I import into Mozmill Editor to run the script.

Using Mozmill 1.0 with latest TB debug checkout. The scripts had worked fine in Mozmill 1.0 for Mac from previous testing.
I've seen the same with latest MozMill trunk on OS X yesterday. Hadn't time to file it yet. Thanks Gary! One test did run but has been finished a couple of minutes later. Do we have a timing problem?
OS: Windows XP → All
Hardware: x86 → All
Updating the summary accordingly. And yes, I've seen that with Firefox.
Summary: Mozmill doesn't work in TB Windows XP → Mozmill tests run mostly forever and don't stop
Is there anything in the Error Console?
(Reporter)

Comment 4

10 years ago
I don't think I'm seeing the same issue as whimboo in comment #1. I had meant https://bugzilla.mozilla.org/show_bug.cgi?id=471510#c5 runs fine on Mac but fails in XP. I'll be trying again to see what shows up in the Error Console.
According to Adam there is an issue with the hiddenDOMWindow.

Upon further investigation the hiddenDOMWindow is not consistent across different operating systems.

I'll be working today to remove all of our use of hwindow in mozmill.
The Windows bug should be fixed in trunk.

Please verify windows issues are fixed so that I can merge the changes to the branch and push a bugfix release.
Created attachment 357259 [details]
Running Test... (forever)

I created a fresh xpi from latest trunk and I'm able to see this bug while running the attached test in Minefield. The test doesn't stop. The following error is shown in the Error Console:

Error: document is null
Source File: chrome://mozmill/content/output.js
Line: 117

Source:
// Set UI Listeners in frame
function stateListener (state) {
  if (state != 'test') {  
--> document.getElementById('runningStatus').textContent = state;
    // results.write(state)
  }

Comment 8

10 years ago
Mikeal was seeing this locally as well, but said he fixed it by turning off another firefox extension, Mikeal can you comment?

Comment 9

10 years ago
I changed document to window.document in revision 295 and it appears to have fixed the problem, please verify.
Yeah, i just ran a bunch of tests on a clean Minefield and it's fine.

Henrik, do you have anything installed in your local Minefield?
Ok, that fixes it at least for me on OS X. Gary should test again with Tunderbird.

Yeah, the following extensions as usual:
DOM Inspector 2.0.1
Firebug 1.4X.0a11
MozMill 1.0
Nightly Tester Tools 2.0.2

Comment 12

10 years ago
No action on this one, please re-open if anyone finds this isn't fixed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Resolution: FIXED → INCOMPLETE
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.