Closed Bug 473091 Opened 11 years ago Closed 11 years ago

Saved Search doesnt allow "Tags isn't empty"

Categories

(MailNews Core :: Search, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: mitra_lists, Assigned: rkent)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090106 Shredder/3.0b2pre

If you try and search a mailbox, it allows "Tags is empty" as a criteria, but not "Tags isn't empty".

Reproducible: Always

Steps to Reproduce:
1.Select Mailbox
2.Search Messages
3.Tags
Actual Results:  
list containing "contains, doesn't contain, is, isn't, is empty

Expected Results:  
isn't empty

This seems an arbitrary omission, and its a meaningful search to create a search folder containing all tagged items (e.g. if you use tags as flags of actions needed).
There are no other search criteria that are "isn't empty" otherwise I probably would have included this in bug 217034. I can't think of any major obstacles in doing this, though.

I'm going to take this for now since I am familiar with the code, but I'm not making any promises of when I will get to it.
Assignee: nobody → kent
Severity: normal → enhancement
Status: UNCONFIRMED → ASSIGNED
Component: General → Search
Ever confirmed: true
OS: Mac OS X → All
Product: Thunderbird → MailNews Core
QA Contact: general → search
Hardware: PowerPC → All
Version: unspecified → Trunk
Attached patch the fix (obsolete) — Splinter Review
Attachment #363068 - Flags: superreview?(bienvenu)
Attachment #363068 - Flags: review?(neil)
Target Milestone: --- → Thunderbird 3.0b3
Attachment #363068 - Flags: review?(neil) → review+
Comment on attachment 363068 [details] [diff] [review]
the fix

>-[scriptable, uuid(82cc4518-304e-11d3-831d-00a0c900d445)]
>+[scriptable, uuid(9B3B2BA5-94E9-440c-856E-487078E3B0DD)]
Actually nobody cares what uuid this interface has, as it's only got constants.

>+    const nsMsgSearchOpValue IsntEmpty = 18; /* primarily for tags */
It's a pity we can't renumber the constants though ;-)

Code in nsMsgSearchTerm::MatchString exists to support IsEmpty. It might have no callers yet, but I think you should implement IsntEmpty there too.
Implemented Neil's comments, carrying over r+
Attachment #363068 - Attachment is obsolete: true
Attachment #364713 - Flags: superreview?(bienvenu)
Attachment #364713 - Flags: review+
Attachment #363068 - Flags: superreview?(bienvenu)
Whiteboard: [needs sr bienvenu]
Attachment #364713 - Flags: superreview?(bienvenu) → superreview+
I missed the sr - adding checkin-needed. Though that patch is a couple of weeks old it still seems to apply OK withh offset.
Keywords: checkin-needed
Whiteboard: [needs sr bienvenu] → [needs checkin]
Checked in: http://hg.mozilla.org/comm-central/rev/c55d44c0a936
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [needs checkin]
You need to log in before you can comment on or make changes to this bug.