Some product names can lead to invalid file names in data/mining/ (for old charts)

RESOLVED FIXED in Bugzilla 5.0

Status

()

RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: aliustek, Assigned: Wurblzap)

Tracking

Bugzilla 5.0

Details

(Whiteboard: [Blocker will fix])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: 3.2

Bugzilla allows Product names to contain *<>":?/\| which are illegal file names. This becomes a problem for sanitycheck as data mining file cannot be created for the product containing illegal file name character

Reproducible: Always

Comment 1

10 years ago
collectstats.pl correctly converts / to - since Bugzilla 2.12, see bug 44653. Nothing is done about the other characters you mentioned. That being said, the code in collectstats.pl is pretty weak and doesn't make sure product "a/b" doesn't mix its data with product "a-b". This is a problem with old charts.
Assignee: administration → charting
Status: UNCONFIRMED → NEW
Component: Administration → Reporting/Charting
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → 3.2

Updated

10 years ago
Summary: Bugzilla allows illegal file names to be product names → Some product names can lead to invalid file names in data/mining/ (for old charts)
(Reporter)

Comment 2

10 years ago
Wouldn't not allowing illegal chars in the first place is a better option

Comment 3

6 years ago
This will be fixed by bug 604388 as we no longer use the product name to generate the file name.
Assignee: charting → bugzilla.1.wurblzap
Depends on: 604388
Whiteboard: [Blocker will fix]
Target Milestone: --- → Bugzilla 4.4

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: Bugzilla 4.4 → Bugzilla 5.0
You need to log in before you can comment on or make changes to this bug.