Personal Toolbar bookmarks should not display tooltip

RESOLVED WONTFIX

Status

P4
normal
RESOLVED WONTFIX
19 years ago
14 years ago

People

(Reporter: nbhatla, Assigned: bugs)

Tracking

({polish})

Trunk
mozilla1.0
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Instead of displaying a URL tooltip on mouseOver, the personal toolbar bookmarks
should display their URL in the status bar where all other URLs are displayed.
This move would be consistent with the existing paradigm of personal toolbar
bookmarks behaving as hyperlinks rather than buttons.
(Reporter)

Updated

19 years ago
Keywords: polish

Comment 1

19 years ago
A valid point, but they aren't presented as links, so the user might not know
what they are, nor do they have other link affordances (d&d, save as, open in
new, etc).  I think very few people care what URL is underneath, once they have
created a bookmark for it. In any case, no time to consider this for N6, ->future.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 2

19 years ago
Hmm...interesting proposal.  Actually, we do sort of present them as links -- 
they're blue, underlined, and turn red on mousedown.  reassigning to me...
Assignee: trudelle → BlakeR1234
Status: ASSIGNED → NEW

Comment 3

19 years ago
None of that applies to the personal toolbar items I see, is that specific to a 
particular platform/skin?  Also, my toolbar items have icons, but don't get a 
context menu, and don't change color after visiting.  
(Reporter)

Comment 4

19 years ago
Yeah, this is specific to the Mac Classic Skin.  And no, they do not change
colors after visiting, only on a mouseDown.  Under the surface they are really
buttons, but we have given them an appearance of hyperlinks.

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: P3 → P5

Comment 5

18 years ago
hmm.  This is actually win32 4xp.  4.x on win32 displays the URL in the 
statusbar and the title of the page in a tooltip (which is pretty useless most 
of the time).

need a UI/UE decision here, keeping in mind that PT buttons only really resemble 
hyperlinks in the classic skin.
Keywords: 4xp
Whiteboard: [NEED UI DECISION]

Comment 6

18 years ago
> nor do they have other link affordances (d&d, save as, open in new, etc)

Ah, but they *should* have these affordances (4xp on Mac is to allow dragging of 
PT bookmarks) ... IMO, bookmarks should have the same behavior as normal links --  
dragging them should do the same as for links, right-clicking on them should give 
the same context menu as is shown for a link in a Web page ... and hovering over 
them should show their URL in the status bar.

Note that often links in Web pages don't look like links either (they look like 
buttons or whatever), but we still show their URLs in the location field. 
Appearance should not be considered to be a barrier here.

Updated

18 years ago
Component: XP Toolkit/Widgets → XP Apps: GUI Features
OS: Mac System 8.5 → All
Priority: P5 → P4
QA Contact: jrgm → sairuh
Whiteboard: [NEED UI DECISION]
Target Milestone: Future → mozilla1.0
QA Contact: sairuh → claudius

Comment 7

18 years ago
giving back to Ben for now....
Assignee: blakeross → ben
Status: ASSIGNED → NEW
QA Contact: claudius → sairuh
QA Contact: sairuh → tpreston
pardon the spam: personal toolbar bugs should go into the Bookmarks component.
so, i'm moving the existing ones from xp apps/xp apps: gui to there...
Component: XP Apps: GUI Features → Bookmarks

Comment 9

18 years ago
Since PT bookmarks don't display more than 13 chars of their name if it's too
long, I think the tooltip should contain the bookmark's name instead of URL.

As Trudelle mentions; if the users has a bookmark in the toolbar they don't care
about the URL - if they want to go there they just click it.

Maybe we should send this bug to UI: Design Feedback component for further
discussion?
WONTFIX.

Please file a bug saying that they should display title or (my favorite) 
title\nURL combo. (like IE)
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
*** Bug 129832 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.