Closed Bug 473239 Opened 13 years ago Closed 13 years ago

Firefox crashes after creating new folder in Bookmark Menu and dragging bookmark to folder. [@ nsXPCOMCycleCollectionParticipant::Unroot(void*) ]

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows Vista
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 446620

People

(Reporter: jrcantwell21, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Opened the "Organize Bookmarks..." window. Clicked on "Bookmarks Menu" on the left plane. Once the Bookmarks Menu opened in the right plane, I righted clicked and choose "New Folder". After I created the folder, I proceeded to drag and drop Bookmarks into the newly created folder. After moving a few bookmarks Firefox crashes. Or if you hold the bookmark over the folder for the folder to open, Firefox crashes whenever it tries to change to the new folder.

Reproducible: Sometimes

Steps to Reproduce:
1.Open "Organize Bookmarks"
2.Click on "Bookmark Menu" in the left plane.
3.Create a new folder.
4.Start dragging bookmarks from the Bookmark Menu to the newly created folder.
5.Try hovering over the new folder to open the folder before dropping the bookmark.
Actual Results:  
Sometime it works fine; however, other times Firefox crashes completely. The whole program crashes and must be reopened.

Expected Results:  
Bookmarks should have been moved without incident or resulting in a program crash.

Aero is turned off in Vista. Yahoo Messenger was also open at the time and FrostWire was running in the background.  My antivirus is Avast.  Only site was open when crash occurred.
Stacktrace on bug report:

0c244b96-aef5-4bae-968a-b866a2090112	1/12/2009	3:54 PM
7450d558-3db1-4add-9f74-a8d072090112	1/12/2009	3:48 PM
9fe20929-621c-4443-953b-558482090112	1/12/2009	3:42 PM
bp-0c244b96-aef5-4bae-968a-b866a2090112
0  	xul.dll  	nsXPCOMCycleCollectionParticipant::Unroot  	nsCycleCollectionParticipant.cpp:74
1 	xul.dll 	nsNavHistoryResult::OnItemMoved 	mozilla/toolkit/components/places/src/nsNavHistoryResult.cpp:4245
Summary: Firefox crashes after creating new folder in Bookmark Menu and dragging bookmark to folder. → Firefox crashes after creating new folder in Bookmark Menu and dragging bookmark to folder. [@ nsXPCOMCycleCollectionParticipant::Unroot(void*) ]
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 446620
You need to log in before you can comment on or make changes to this bug.