Closed Bug 473281 Opened 11 years ago Closed 7 years ago

[win32] ###!!! ASSERTION: Failed to create the object: 'Error' in dom/src/base/nsDOMClassInfo.cpp:5011

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: nthomas, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Over the last 5 days we've hit 3 of these in mozilla-central leaktest builds, and 4 in mozilla-1.9.1 leaktest builds. It's older than that though, I reported something similar in bug 471950.

This is occurring on 5 separate slaves [1] so either there's something screwy in the build system that's leading them all into a confused state or a genuine bug here. Can't find this on linux or mac over the same period.

[1] moz2-win32-slave15,07,05 for m-c; 15,06,09 for m-1.9.1
There's also

WARNING: NS_ENSURE_TRUE(doc) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/html/content/src/nsHTMLImageElement.cpp, line 168

which means nsContentUtils::GetDocumentFromCaller() failed to return a document.
You can run the same leaktest those machines do by running:
python $OBJDIR/_leaktest/leaktest.py
There were 19 instances of this assertion over the last 5 days, spread over these commands
  7 counts: python leaktest.py -- -CreateProfile default
  7 counts: python leaktest.py -- -P default
  7 counts: python leaktest.py -l bloat.log
and the mozilla-central and mozilla-1.9.1 trees. Each one of those is a false red on the tree, so could we get someone's time to figure out what is going here ?
Flags: blocking1.9.1?
Do we have a time window when this started happening?
Have asked IT for data from the tinderbox server to attempt to figure that out. Logs there go back 61 days.
The assertion goes back to at least November 22, the oldest logs tinderbox has for the Firefox tree. I've asked for the same check on Firefox3.1 in the hope the cause landed there later.
(In reply to comment #7)
> The assertion goes back to at least November 22, the oldest logs tinderbox has
> for the Firefox tree. I've asked for the same check on Firefox3.1 in the hope
> the cause landed there later.

Same for Firefox3.1.
While this is obviously really bad over all, we're not going to hold the release for it, as it's not something that we've seen in the wild as of yet, as far as we know.
Flags: wanted1.9.2+
Flags: wanted1.9.1+
Flags: blocking1.9.1?
Flags: blocking1.9.1-
It does make the leak test boxes go red on occasion though, so it's quite annoying.
Blocks: 438871
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241634822.1241635249.31925.gz
(mozilla-central Linux leak test)
OS: Windows Server 2003 → All
Hardware: x86 → All
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.