Can't open .mozeml file

RESOLVED FIXED in Thunderbird 3.0b3

Status

Thunderbird
General
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Yuxuan Wang, Assigned: humph)

Tracking

unspecified
Thunderbird 3.0b3
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.6pre) Gecko/2008121820 Camino/2.0b1 (like Firefox/3.0.6pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090112 Lightning/1.0pre Shredder/3.0b2pre

After enabled mail.spotlight.enable, look into Finder for generated .mozeml files. Double click them will open them by TextEdit, if specify to use Thunderbird.app/Shredder.app to open these files, Thunderbird will just open a write mail window, but not the message.

Reproducible: Always
(Assignee)

Comment 1

9 years ago
Where are these files when you open them, which dir?
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Where are these files when you open them, which dir?

for example:
/Users/fishy/Library/Thunderbird/Profiles/d67mtbv0.default/Mail/Local Folders/Inbox.mozmsgs
(Assignee)

Comment 3

9 years ago
Created attachment 360969 [details] [diff] [review]
[WIP] fix Info.plist files

I think we're doing our Info.plist files wrong, esp. where we define .mozeml.  See http://lists.apple.com/archives/Spotlight-dev/2007/Jul/msg00019.html

I'd appreciate if you could look at this.  I'm still not 100% of all aspects of these files, but this is closer, I think.

I've also added an entry for 'eml' files, since I'm in here.
Attachment #360969 - Flags: review?(bugzilla)
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> Created an attachment (id=360969) [details]
> [WIP] fix Info.plist files
> 
> I think we're doing our Info.plist files wrong, esp. where we define .mozeml. 
> See http://lists.apple.com/archives/Spotlight-dev/2007/Jul/msg00019.html
> 
> I'd appreciate if you could look at this.  I'm still not 100% of all aspects of
> these files, but this is closer, I think.
> 
> I've also added an entry for 'eml' files, since I'm in here.

I can't apply this patch against the Info.plist in my Feb. 5th nightly:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090205 Lightning/1.0pre Shredder/3.0b2pre

As there're too much differences. Could you please attach an already patched Info.plist?

And as I mentioned, I think besides patching Info.plist, there have something else to do in the code. I've tried to open the .mozeml files with Thunderbird (this is to be done with the plist patch), but Thunderbird just didn't open the mail, but open a write new mail window.
Comment on attachment 360969 [details] [diff] [review]
[WIP] fix Info.plist files

In combination with the patches on bug 290057 and bug 468471 this works nicely. r=me.

Checked in as well: http://hg.mozilla.org/comm-central/rev/674f6c68cb1a
Attachment #360969 - Flags: review?(bugzilla) → review+
Assignee: nobody → david.humphrey
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b3
You need to log in before you can comment on or make changes to this bug.