Move Message displays "Re:" before the Subject text, NT4

VERIFIED FIXED in M5

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
NT4, Build 4/7/99, Apprunner's Browswer window shows Build ID 1999040710 in the
bottom right corner of the screen.

Problem: Highlight a message in the Inbox, notice the Subject (i.e. Test),
select the Message menu, select Move Message and choose a folder (i.e. FolderA).
Go to FolderA and notice that the message is there but it now begins with an
"Re:" so it actually displays "Re: Test".

I tried switching to a different folder and switching back but the "Re:"
remains. If I exit and restart Mail and switch to FolderA then the "Re:"
no longer exists and the subject displays correctly, "Test". I reproduced this
on Fenella's NT4.0 system.

The same scenario in Win95 never displays a subject with an "Re:" so it appears
to be an NT4.0 problem.

Updated

20 years ago
Assignee: phil → bienvenu

Comment 1

20 years ago
I'm going to reassign this to bienvenu, but there may not be a bug here.

Could you look in 4.5 and make sure that the original message doesn't have a Re:
in front of it before you move it.

There were some status problems that David fixed earlier this week that required
you to delete your .msf files.  To do this, go into the directory that holds
your mail folders.  Look for the files that end in .msf and delete them.  Then
run again.

I tried this and it isn't happening to me.

Comment 2

20 years ago
I looked at Ninoschka's machine and saw what was happening.  Ignore my previous
response.

I think this is happening because we're not copying over all of the fields in
the header when we do CopyMsgFromHdr.  So, the date and flags are wrong.  When
you start up again and are actually reparsing the mailbox, everything looks ok.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M5
(Assignee)

Comment 3

20 years ago
the flags weren't getting copied over. Since the copy hdr code is just a place
holder until mork implements some stuff, this isn't a big deal, so I wouldn't
hold m4 for it.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
fixed in nsMsgDatabase.cpp

Updated

19 years ago
QA Contact: 4080 → 4114

Updated

19 years ago
Whiteboard: Can't verify until bug 5793 is fixed.

Comment 5

19 years ago
Can't verify until bug 5793 is fixed (Move doesn't provide list for moving to).

Updated

19 years ago
QA Contact: 4114 → 4111
Whiteboard: Can't verify until bug 5793 is fixed.

Comment 6

19 years ago
Ninoschka - pls verify.  Bug 5676 is marked fixed so you should be able to
verify.

Bug 5793 has nothing to do w/ this bug.
(Reporter)

Comment 7

19 years ago
Win32 (NT4) build 1999-05-03-08.
Unable to verify this because bug 5676 is still not fixed.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

19 years ago
Win32 (NT4) build 1999-05-04-08.
Verified Fixed. It now moves a message without adding "Re:" before the subject
text.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.