Thunderbird read wrong message time (0.00) in mails sent from Dimac Jmail component

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Federico Polezzi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; GTB5; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; FDM; .NET CLR 1.1.4322; .NET CLR 3.5.21022)
Build Identifier: 2.0.0.19 (20081209)

When I send an email in a procedure that use the Dimac Jmail component, the time displayed in the inbox list, or in the message details is always 0.00 (for example 12/01/2009 0.00)

This is an example raw message from gmail that shows this behaviour in thunderbird, when it's downloaded with the IMAP gmail account:

Delivered-To: name.surname@gmail.com
Received: by 10.180.225.18 with SMTP id x18cs1482989bkg;
        Tue, 13 Jan 2009 01:44:17 -0800 (PST)
Received: by 10.181.144.10 with SMTP id w10mr11327897bkn.30.1231839857409;
        Tue, 13 Jan 2009 01:44:17 -0800 (PST)
Return-Path: <name.surname@testdomain.it>
Received: from hostingsmtp.register.it (paganini04-hosting.register.it [81.88.50.245])
        by mx.google.com with ESMTP id 10si32608086bwz.79.2009.01.13.01.44.17;
        Tue, 13 Jan 2009 01:44:17 -0800 (PST)
Received-SPF: neutral (google.com: 81.88.50.245 is neither permitted nor denied by best guess record for domain of name.surname@testdomain.it) client-ip=81.88.50.245;
Authentication-Results: mx.google.com; spf=neutral (google.com: 81.88.50.245 is neither permitted nor denied by best guess record for domain of name.surname@testdomain.it) smtp.mail=name.surname@testdomain.it
Received: (qmail 21077 invoked from network); 13 Jan 2009 09:44:13 -0000
Received: from unknown (HELO vivaldi36.register.it)
  by hostingsmtp.register.it with ESMTP; 13 Jan 2009 09:44:13 -0000
Received: (qmail 10936 invoked by uid 508); 13 Jan 2009 09:44:12 -0000
Delivered-To: testdomain-it-name.surname@testdomain.it
Received: (qmail 10751 invoked from network); 13 Jan 2009 09:44:11 -0000
Received: from unknown (HELO ext-cn0ut-4.online-asrv.net) (63.210.253.233)
  by vivaldi36.register.it with SMTP; 13 Jan 2009 09:44:11 -0000
Received-SPF: none (vivaldi36.register.it: domain at testdomain.it does not designate permitted sender hosts)
Received: from int-cn0ut-4.online-asrv.net (int-cn0ut-4.online-asrv.net [3.159.252.73])
	by ext-cn0ut-4.online-asrv.net (8.13.6/8.13.6/20051114-SVVS-TLS-DNSBL) with ESMTP id n0D9i83j023176
	for <name.surname@testdomain.it>; Tue, 13 Jan 2009 04:44:09 -0500
Received: from cinmlip01.e2k.ad.srv.com (int-cn0ut-4.online-asrv.net [3.159.252.73])
	by int-cn0ut-4.online-asrv.net (8.13.6/8.13.6/20050510-SVVS) with ESMTP id n0D9i86r002904
	for <name.surname@testdomain.it>; Tue, 13 Jan 2009 04:44:08 -0500
Received: from servername.srv.srv.com (HELO smtpservername.e2k.ad.srv.com) ([3.151.208.210])
  by cinmlip01.e2k.ad.srv.com with ESMTP; 13 Jan 2009 04:44:08 -0500
Received: from servername.srv.srv.com ([127.0.0.1]) by smtpservername.e2k.ad.srv.com with Microsoft SMTPSVC(6.0.3790.3959);
	 Tue, 13 Jan 2009 10:44:07 +0100
Subject: testw
Sender: "=?iso-8859-1?Q?name=2Esurname@testdomain=2Eit?=" <name.surname@testdomain.it>
From: "=?iso-8859-1?Q?name=2Esurname@testdomain=2Eit?=" <name.surname@testdomain.it>
Date: Tue, 13 Jan 2009 10.44.07 +0100
To: "=?iso-8859-1?Q?name=2Esurname@testdomain=2Eit?=" <name.surname@testdomain.it>
X-Priority: 3
Content-Transfer-Encoding: Quoted-Printable
MIME-Version: 1.0
X-Mailer: JMail 4.5 by Dimac
Message-ID: <servernameNjVuMh000000e4@smtpservername.e2k.ad.srv.com>
X-OriginalArrivalTime: 13 Jan 2009 09:44:07.0851 (UTC) FILETIME=[7AC1E7B0:01C97563]

I've only renamed some private names.
In this mail there isn't the body, but it's irrilevant.

I've tried to change the charset and encoding from Jmail properties but it hasn't sorted any better effect.

In Microsoft Outlook with pop3 or IMAP account these mails shows the right time.

Reproducible: Always

Steps to Reproduce:
1. Send an email with JMail 4.5 component by Dimac from an ASP page
2. Check the messsage date time on thunderbird, in all my tests the time is 0.00



This happens in thunderbird 2 with or without addons, and even with thunderbird 3 beta.
(Reporter)

Updated

9 years ago
Summary: Thunderbird read wrong message time (0.00) in mails sent from Dimac Jmail comonent → Thunderbird read wrong message time (0.00) in mails sent from Dimac Jmail component
>Date: Tue, 13 Jan 2009 10.44.07 +0100
This date header violates RFC822 because it's using "." instead of ":".
- http://www.w3.org/Protocols/rfc822/#z28

time        =  hour zone                    ; ANSI and Military

hour        =  2DIGIT ":" 2DIGIT [":" 2DIGIT]
                                            ; 00:00:00 - 23:59:59
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.