Closed Bug 473364 Opened 12 years ago Closed 12 years ago

Exception in case wrong url to remote location of ics url

Categories

(Calendar :: Provider: ICS/WebDAV, defect)

Lightning 0.9
x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 314594

People

(Reporter: 29l84a402, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.5) Gecko/2008121911 CentOS/3.0.5-1.el5.centos Firefox/3.0.5
Build Identifier:  Lighting 0.9 (build 2008091718), Thunderbird 2.0.0.19 (20090107)

When wrong URL to ics is provided raises exception.


[Exception... "Component returned failure code: 0x804b0012 
[nsIIOService.newChannelFromURI]"  nsresult: "0x804b0012 (<unknown>)"  location: "JS frame :: file:///home/abicz/.thunderbird/bk4jxda5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendarModule.js -> file:///home/abicz/.thunderbird/bk4jxda5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calICSCalendar.js :: anonymous :: line 130"  data: no]`


Reproducible: Always

Steps to Reproduce:
1.New Calendar
2.Remote Calendar
3.Format ICS
4.Location provide wrong url like : tp://calendar@cypisek.dotsystems.pl/calendars/dotsystems.ics
Actual Results:  
Throws exception like : 

[Exception... "Component returned failure code: 0x804b0012 [nsIIOService.newChannelFromURI]"  nsresult: "0x804b0012 (<unknown>)"  location: "JS frame :: file:///home/abicz/.thunderbird/bk4jxda5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendarModule.js -> file:///home/abicz/.thunderbird/bk4jxda5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calICSCalendar.js :: anonymous :: line 130"  data: no]`


Expected Results:  
It should inform that it can not connect to URL or format of URL is incorrect.
Version: unspecified → Lightning 0.9
Seems to be related to or duplicate of Bug 314594.
yes it is right
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 314594
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.