It's not possible to use the onboard bayesian filtering result as a component of a created filter rule.

RESOLVED DUPLICATE of bug 196036

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 196036
10 years ago
10 years ago

People

(Reporter: Charlie Derr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: version 2.0.0.19 (20090103)

I've given my own info above (I'm actually running icedove on debian/GNU linux) but this is a generic problem with thunderbird and is not specific to any platform.  This is definitely a wishlist item (functionality that doesn't yet exist is being requested).   It would be a significantly more useful if after enabling adaptive junk mail controls (in Account Settings) that this information (yes/no on junk status) could be used alongside other filter rules in creating filters (to move messages into specific subfolders).

Reproducible: Always

Steps to Reproduce:
1. In Account Settings, go to Junk Settings and click the checkbox to "Enable adaptive junk mail controls for this account"
2. From the Tools menu go to Message Filters and click the "New" button
3. In the left-most drop down list I want one of the options (in addition to Subject, From, Date, etc...) to be "Junk" (or whatever else you'd prefer to call "junk status" as determined by thunderbird's adaptive filtering (I presume Bayesian) analysis.
Actual Results:  
The Customize option doesn't do the job because it's analyzing only email header data (and as far as I can tell, tbird's internal adaptive filtering doesn't add a new header to messages depending on the result of the analysis).

Expected Results:  
Everything works fine, it could just be more convenient.

There are several ways to enable the extra functionality being requested, any that allow a filter rule to be constructed which includes tbird's internal Bayesian analysis as a component of more complex filter rules will be acceptable.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 196036
You need to log in before you can comment on or make changes to this bug.