Tabs within print preview

RESOLVED DUPLICATE of bug 249919

Status

()

Core
Print Preview
RESOLVED DUPLICATE of bug 249919
9 years ago
9 years ago

People

(Reporter: Dietmar Rabich, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Tabs are shown within print preview. Sometimes another page is shown too.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox and show a page.
2. Open a second tab and load a document with a script which writes to "opener.document". Best way together with "settimeout".
3. Switch (not close) to the first tab and choose print preview.
4. Wait for call of the function in "settimeout"
Actual Results:  
Tabs (and more pages than expected) are shown within print preview.

Expected Results:  
No tab will be opened, the original page should be visible (and printable).

Here is a sample to reproduce this nice behaviour:

<html>
<head>
<title>Test</title>
<script type="text/javascript">
<!--
function test () {
	var w = window.open("", "AnotherWindow");
	w.document.write(
		'<html><head>' +
		'<script type="text/javascript">' +
		'with(opener) {document.write("Hi!");document.close();}' +
		'</script></head>' +
		'<body>Wait</body></html>'
	);
	w.document.close();
}
window.setTimeout("test()", 10000);
//-->
</script>
</head>
<body>
Empty
</body>
</html>

Use of "settimeout" and "opener" is very important.

You can reproduce it with other software too. For example the backend of the content management system TYPO3 asks sometimes for a re-login or it does the re-login by itself. If print preview is open at this time the backend of TYPO3 (with frames) is shown in the print preview instead of the page you would like to see.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch
Created attachment 356777 [details]
reporter's testcase

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.
WFM
Component: General → Print Preview
Product: Firefox → Core
QA Contact: general → printing
Version: 3.0 Branch → 1.9.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 249919
You need to log in before you can comment on or make changes to this bug.