Unable to download extensions under Windows 7 Beta (Download error -228)

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Steve Sekula, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

The problem the following when using Windows 7 Beta:

* I try to install any addon to Firefox 3.0.5
* the installation dialog appears. I click the "Install" button after the countdown has concluded
* Firefox waits (I assume trying to download the extension). It times out with the following error:

Firefox could not install the file at 
https://addons.mozilla.org/downloads/file/42605/colorfultabs-3.8-fx.xpi
because: Download error
-228

I also punched this URL (or any other such .xpi extension URL) into Internet Explorer, and it too could not communicate with the site. However, I switched to Linux on the same machine (same hardware, same network card, etc) I have no problem accessing extensions, downloading and installing them. I was skeptical that the problem was specific to Windows 7, and I still am, so I would appreciate somebody trying this and confirming/refuting the observation.

Reproducible: Always

Steps to Reproduce:
1. Choose an extension to install in Firefox 3.0.5
2. Try to install it, or try to access the URL directly in any web browser

Actual Results:  
Error downloading the extension (accessing the site) is reported

Expected Results:  
I expected the extension to be downloaded and installed

I tried to see if the use of a secure HTTP server was the problem, but I had no problem accessing several other secure servers. I see no network access error messages in Windows, and can easily browse other sites even while unable to access the extension URL.
(Reporter)

Updated

10 years ago
OS: Other → Windows 7

Updated

10 years ago
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager

Updated

10 years ago
Summary: Unable to access extensions in Windows 7 Beta → Unable to download extensions under Windows 7 Beta (Download error -228)
Installing addons works just fine for me on Firefox: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-IN; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 (.NET CLR 3.5.30729)

...and on Minefield: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-IN; rv:1.9.2a1pre) Gecko/20090113 Minefield/3.2a1pre (.NET CLR 3.5.30729) Ubiquity/0.1.3 

Download error -228 is described at <http://support.mozilla.com/en-US/kb/Unable+to+install+add-ons#Download_Error_228> -- please make sure your cache isn't disabled, and that you have nothing blocking Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

10 years ago
Hi Siddharth,

I checked the cache; it was enabled. I removed AVG anti-virus, which on Windows XP had not blocked Firefox. That seems to have cleared up the problem. So it's AVG's problem. I'll leave it uninstalled so I can enjoy Firefox.

Cheers,
Steve
You need to log in before you can comment on or make changes to this bug.