Attachments suspend in Thunderbird (Not Responding) until download is complete

RESOLVED INCOMPLETE

Status

Thunderbird
Message Reader UI
RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: Richard L. Whitmore, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-06-20)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: version 2.0.0.19 (20081209)

I have a  radio station and many of the programs that we play come in as attachments. When any type of attachment comes in, Thunderbird just quits responding until all messages with attachments and any other big messages has completed downloading.

I thought it may be a problem with my anti-virus program, but I disabled that and I still have this problem.

Other programs work while Thunderbird is in the "not responding" state. The compose module also quits responding until the incoming message(s) has finished.

It also appears that messages with a lot of text in the body also causes this problem, but it is more like just a second or two delay instead of sometimes up to a minute of no response.

Reproducible: Always

Steps to Reproduce:
1.Send an attachment of at least 1 meg
2.Send several attachments at the same time
3.Send multiple emails with videos, photos, sound files
Actual Results:  
When these attachments arrive, you will see that the Thunderbird program quits responding. If you are in the process of reading or composing a new message, it also quits responding until the incoming message(s) has completely arrived, then functionality returns.

Expected Results:  
I have observed that when these same type attachments are received in Outlook Express, Outlook Express does not suspend while the attachment(s) is/are arriving.

I would like to see that Thunderbird would continue to respond to commands while large emails are arriving.

Comment 1

8 years ago
Richard, does version 3 behave better in this respect?
Component: General → Message Reader UI
QA Contact: general → message-reader
Whiteboard: closeme 2010-05-01
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

8 years ago
Still have trouble with Thunderbird freezing (not responding) until large attachments have completed downloading. It even stops the compose window until the attachment has completed downloading.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 4

8 years ago
Richard, last v3.1 beta is ready which you can test from http://www.mozillamessaging.com/thunderbird/early_releases/downloads/

what antivirus sofwtare do you run?
and what is the size of the file of your inbox on disk?
 described at http://support.mozillamessaging.com/en-US/kb/Profiles
Keywords: perf
Whiteboard: closeme 2010-05-01
(Reporter)

Comment 5

8 years ago
I am downloading the beta now, but I ask, "will this fix my 'not responding' problem during downloading?"

The inbox size is only 118 megs.

I run Microsoft Security Essentials, but have also used AVG & Avast. Same results.

Richard.

Comment 6

8 years ago
(In reply to comment #5)
> I am downloading the beta now, but I ask, "will this fix my 'not responding'
> problem during downloading?"

unknown.  latest build of 3.1 is at http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/3.1rc1-candidates/build2/
Whiteboard: closeme 2010-06-20
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.