Status bar not updating properly

VERIFIED FIXED

Status

SeaMonkey
UI Design
P3
major
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Nikhil Bhatla (gone), Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
In yesterday's 2000080108-M18 build:

The status bar on the macintosh does not display status properly.  
Instead of giving the usual "connecting to server", "sending...", and other 
status messages as a web page loads, the only message it ever displays 
is the "Document Done (time)" after the page finishes .

Warren, I heard from Ben that you had made some changes to status bar 
display.  Could this bug be because of that?

Comment 1

18 years ago
For that matter, the "Applet Loaded" message stays in the status bar after a
Java applet has been loaded, even though the page you might be surfing on has no
Java applet to load.

See my comments on bug 36381 from today.  Same iMac DV, MRJ 2.2.2, Mac OS 9.0.4.
 Also build 2000080108-M18.

Comment 2

18 years ago
I know nothing...
Assignee: warren → trudelle

Comment 3

18 years ago
I only know this isn't toolkit.  ->xpapps.
Assignee: trudelle → ben
Component: XP Toolkit/Widgets → XP Apps: GUI Features
QA Contact: jrgm → sairuh
claudius, man of statusbar and the mac!
QA Contact: sairuh → claudius
(Assignee)

Comment 5

18 years ago
*** Bug 55524 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

18 years ago
This is broken on Windows, too.

Changed summary/platform/os and reassigned to me.  It looks like a networking
notification problem of some sort.  By rights this should have been a PR3/rtm
bug but it's too late now.
Assignee: ben → law
OS: Mac System 9.0 → All
Hardware: Macintosh → All
Summary: [MAC] - StatusBar not updating properly → StatusBar not updating properly

Comment 7

18 years ago
On win it is broken for a while now... 2 months or so? 

Comment 8

18 years ago
Any news?
Severity: normal → major

Comment 9

18 years ago
Marking [rtm need info] coz we do not see what is the browser doing. This forced 
me many times to reload not completely loaded pages, coz I thought there was 
some error loading it (but it was just not loaded).
Whiteboard: [rtm need info]
(Assignee)

Comment 10

18 years ago
I *think* the right protocol is to nominate via the "rtm" keyword, then let the
assignee and their manager decide to mark it [rtm need info] (if they think it
worthy of the expenditure of effort).

So, I've cleared the status whiteboard and added the keyword.

My recommendation, unfortunately, is to [rtm=] this one, for the following reasons:

1. The consequences aren't severe enough to warrant fixing at this stage of the
game.  Nobody has much complained in the two months that it's not been working
(a dup showed up just recently and this one never got nominated for pr3 or rtm).
 The error is mostly cosmetic.
2. The fix is likely to involve code that we don't have the time nor energy to
risk hacking on right now (networking notifications and webshell).
3. The fix is likely to be complicated.
Keywords: rtm
Whiteboard: [rtm need info]

Comment 11

18 years ago
I agree with Bill.  Well, maybe not the "rtm=" part. :-)  So I'll minus it instead.
Whiteboard: [rtm-]

Updated

18 years ago
Summary: StatusBar not updating properly → Status bar not updating properly
*** Bug 57023 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
Any news? We want know what Mozilla is doing at the moment...

Comment 14

18 years ago
Well... it's still here.  The "Applet Loaded" message though, doesn't stay
around like it used to.

Seeing this today with Mac Mozilla trunk installer build 2000102312, running
under Mac OS 9.0.4.

Comment 15

18 years ago
This is happening on linux 20001027, too. For some reason the build I just
downloaded is not showing the build # in the title bar!

This is a really serious bug. Everyone needs to know when the program is
connecting or transferring, so they don't think something is wrong with the browser.

Comment 16

18 years ago
Latest update:  under Mac OS 9.0.4 with MRJ 2.2.3 installed, Mac Mozilla
Installer build 2000111708, the following happens.

Instead of the "Document:  Done (x.xx secs) note at the bottom of the status
bar, I get "An unknown error has occurred (804b000x)" where x is a number
between 3 and 7.  Tested Mozilla as shipped, no new plug-in or MacsBug installed.
Regression keyword needs added -- I'm not sufficiently empowered -- this did not
happen in M-trunk build 2000110808 on the same iMac DV.

Comment 17

18 years ago
That is bug 60161.

Comment 18

18 years ago
Okay... so we have a different bug to keep track of what I just reported, and
this isn't related to this bug?

Call in the bugzilla referees...

Updated

18 years ago
Depends on: 60161

Comment 19

18 years ago
using build 2000113020 with win98.

with bug 60161 fixed, a similar bug seems to appear - instead of showing the
loading progress of a page in the status bar, only the message "sending request
to <hostname>" appears, where <hostname> is the name of the server being
*currently* accessed (as opposed to the previous server accessed, as with bug
47579).  on occasion, the status bar even reads "read
jar:resource:///chrome/modern.jar!....", but i think this occurs when the
browser reads a part of chrome immediately after loading a page.

mousing over any statusbar-altering object (like a link) resets the status bar
to its proper default.

Comment 20

18 years ago
I think this is fixed now.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Keywords: rtm
Resolution: --- → FIXED
Whiteboard: [rtm-]

Comment 21

18 years ago
this bug might not be technically classified as "fixed" - it just evolved into
bug 62976 after the fix for 60161 was put in.
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.