Closed Bug 473594 Opened 13 years ago Closed 13 years ago

LDAP lookup configuration entries are corrupted

Categories

(MailNews Core :: Address Book, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b2

People

(Reporter: baffoni, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(2 files)

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b3pre) Gecko/20090114 Shredder/3.0b2pre

When I go to tools/options/Composition/Addressing, and look at the LDAP configuration entries, they are all mangled.  Only the name is correct, all other entries including port, base, address, etc, are blank, and the number of entries is 1, and set to individual and not subtree.

Attempting to edit the entries does nothing, they always return to the blank setting.

Lookup against ldap therefore fails, however lookups against local address books work normally.
Duplicate of this bug: 473600
Regression from bug 419595, I forgot to add a new file to the packaging, so this is broken on Windows.
Assignee: nobody → bugzilla
Blocks: 419595
Keywords: regression
Target Milestone: --- → Thunderbird 3.0b2
Product: Thunderbird → MailNews Core
QA Contact: address-book → addressbook
Attached patch Thunderbird fixSplinter Review
Add nsLDAPProtocolHandler.js to the Thunderbird packages file - I'll take the first review I get.
Attachment #356979 - Flags: review?(philringnalda)
Attachment #356979 - Flags: review?(bienvenu)
Attached patch SeaMonkey fixSplinter Review
Add nsLDAPProtocolHandler.js to the SeaMonkey packages-static files - I'll take the first review I get.
Attachment #356980 - Flags: review?(neil)
Comment on attachment 356979 [details] [diff] [review]
Thunderbird fix

Yay, I never win these races!

Far as I'm concerned, you can just treat fixing failure to package as a bustage fix.
Attachment #356979 - Flags: review?(philringnalda) → review+
Comment on attachment 356980 [details] [diff] [review]
SeaMonkey fix

>+bin/components/nsLDAPProtocolHandler.js
> bin/components/libmozldap.so
> bin/components/mozldap.xpt
After mozldap.xpt here too, please.
Attachment #356980 - Flags: review?(neil) → review+
Attachment #356979 - Flags: review?(bienvenu)
Both patches checked in with one changeset: http://hg.mozilla.org/comm-central/rev/dadf1bba728c
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Duplicate of this bug: 473715
I can say that for me it works perfectly now!  Great job, everyone!
This is not fixed here.  I still recieve errors as described in #473715.
Note that I am using nightly builds (currently 20090115).
Thanks, I see it as well, I've reopened your bug and will look at it there.
It is working for me only if I do a lookup from the addressbook.  When it does a lookup from a new mail compose address line, it says "LDAP initialization problem".
Address book lookups do work now, but only the email address is displayed, despite searching all the fields.
I have to agree with Michael--I thought mine was fixed but now it seems to either say "LDAP initialization problem" or "LDAP server search problem".  :(
As mentioned previously I'll fix the outstanding errors in bug 473715.
You need to log in before you can comment on or make changes to this bug.