Fix the order of member variable in the initialization list

VERIFIED FIXED

Status

Tamarin
Virtual Machine
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Rishit Shah, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: 

The order of member variables in the intialization list for few classes is different than the order of their declaration.  Some compilers give warnings for such code.  This bug is intended to fix such code.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

9 years ago
perhaps most importantly, enable the warning on all gcc-based builds
(Reporter)

Updated

9 years ago
Duplicate of this bug: 473615
(Reporter)

Comment 3

9 years ago
Created attachment 356991 [details] [diff] [review]
Patch to fix up member initialization order [v1]
Attachment #356991 - Flags: review?(treilly)

Comment 4

9 years ago
the offerred patch fixes init order problems, but does nothing to prevent them in the future.  Can we also update the build configs to turn on this warning, or create a separate bug/patch to do that in the (near) future?
(Reporter)

Comment 5

9 years ago
I need to familiarize myself with the existing build configuration.  I will talk to Steven/Lars and follow-up with the changes to fix that.

Comment 6

9 years ago
(In reply to comment #5)
> I need to familiarize myself with the existing build configuration.  I will
> talk to Steven/Lars and follow-up with the changes to fix that.

I'll look into it, since I can test it easily.

(BTW if Tommy is too busy to review the patch promtly you can move it over to me as well and I'll take a look.)

Updated

9 years ago
Attachment #356991 - Flags: review?(treilly) → review+

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 7

9 years ago
Has the necessary change to the build scripts (comment #4) been moved to another issue? There is no comment here that it has been addressed but this issue has been marked as FIXED.

Comment 8

9 years ago
(In reply to comment #7)
> Has the necessary change to the build scripts (comment #4) been moved to
> another issue? There is no comment here that it has been addressed but this
> issue has been marked as FIXED.

I have created a separate issue to track that:
https://bugzilla.mozilla.org/show_bug.cgi?id=475750

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.