Change to fix a private member access error in avmplus::List class

VERIFIED FIXED

Status

Tamarin
Virtual Machine
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Rishit Shah, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: 

In function List::become() the following usage
"list.len"

results in an private member access error in one compiler since "len" is a private member.

Change is to use the accessor function "size()" instead to avoid this error.

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 357001 [details] [diff] [review]
Patch for the fix [v1]
Attachment #357001 - Flags: review?(stejohns)

Updated

9 years ago
Attachment #357001 - Flags: review?(stejohns) → review+

Comment 2

9 years ago
Comment on attachment 357001 [details] [diff] [review]
Patch for the fix [v1]

in theory, should be legal in all compilers since "list" is of same type as "this" and so private members should be accessible, but this fix looks fine

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 3

8 years ago
http://hg.mozilla.org/tamarin-redux/rev/84ee5f44b223
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.