operationLimit assertion failure on OS X

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: sayrer, Assigned: igor)

Tracking

({fixed1.9.1})

unspecified
x86
Mac OS X
fixed1.9.1
Points:
---
Bug Flags:
blocking1.9.1 +
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Assertion failure: operationLimit <= JS_MAX_OPERATION_LIMIT, at /builds/moz2_slave/mozilla-central-macosx-debug/build/js/src/jsapi.cpp:5272

I hit this when I merged to m-c on the leak test box.
Flags: blocking1.9.1+
(Reporter)

Comment 1

10 years ago
js_InitOperationLimit sets this to JS_MAX_OPERATION_LIMIT + 1, which makes this look wrong:

> JS_SetOperationLimit(cx, JS_GetOperationLimit(origCx));
(Reporter)

Comment 2

10 years ago
I wallpapered this for now:

http://hg.mozilla.org/mozilla-central/rev/562d8990f33a
(Assignee)

Comment 3

10 years ago
This is a regression from the bug 472702.
Blocks: 472702
(Assignee)

Comment 4

10 years ago
Created attachment 357150 [details] [diff] [review]
fix v1

My patch for the bug 472702 initializes JSContext.operationLimit to JS_MAX_OPERATION_LIMIT + 1 to detect if the embedding was ever set operation limit for JSContext instance explicitly. This is used by jstracer.cpp not to generate the code to update JSContext.operationCount when the limit is not set assuming that an application will use a separated thread or signals to set JSContext.operationCount to 0.

But I forgot in JS_GetOperationLimit to return JS_MAX_OPERATION_LIMIT, not JS_MAX_OPERATION_LIMIT + 1, so application can freely continue to use JS_(Get|Set)OperationLimit without surprises.
Attachment #357150 - Flags: review?(mrbkap)
Comment on attachment 357150 [details] [diff] [review]
fix v1

Don't forget to back out sayrer's wallpaper from comment 2 out when you check this in! Thanks.
Attachment #357150 - Flags: review?(mrbkap) → review+
(Assignee)

Comment 6

10 years ago
landed to tm - http://hg.mozilla.org/tracemonkey/rev/293624178003
Whiteboard: fixed-in-tracemonkey
(Assignee)

Comment 7

10 years ago
(In reply to comment #5)
> (From update of attachment 357150 [details] [diff] [review])
> Don't forget to back out sayrer's wallpaper from comment 2 out when you check
> this in! Thanks.

Done - http://hg.mozilla.org/tracemonkey/rev/90bdc10e0c83
Duplicate of this bug: 473804
(Reporter)

Comment 9

10 years ago
http://hg.mozilla.org/mozilla-central/rev/293624178003
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: fixed-in-tracemonkey → [needs 1.9.1 landing]

Updated

10 years ago
Flags: in-testsuite-
Flags: in-litmus-
(Reporter)

Comment 10

10 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/9cd0940a9cf2
Keywords: fixed1.9.1
Whiteboard: [needs 1.9.1 landing]
You need to log in before you can comment on or make changes to this bug.