If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Security announcement from drupal.org

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
9 years ago
4 years ago

People

(Reporter: Paul Booker, Assigned: reed)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
---- SA-CORE-2009-001  DRUPAL CORE - MULTIPLE VULNERABILITIES ----

 * Advisory ID: DRUPAL-SA-CORE-2009-001

 * Project: Drupal core

 * Versions: 5.x and 6.x

 * Date: 2009-January-14

 * Security risk: Moderately Critical

 * Exploitable from: Remote

 * Vulnerability: Multiple vulnerabilities

Multiple vulnerabilities and weaknesses were discovered in Drupal.

---- ACCESS BYPASS ----

The Content Translation module for Drupal 6.x enables users to make a
translation of an existing item of content (a node). In that process the
existing node's content is copied into the new node's submission form.

The module contains a flaw that allows a user with the 'translate content'
permission to potentially bypass normal viewing access restrictions, for example
allowing the user to see the content of unpublished nodes even if they do not
have permission to view unpublished nodes.

This issue only affects Drupal 6.x.

---- VALIDATION BYPASS ----

When user profile pictures are enabled, the default user profile validation
function will be bypassed, possibly allowing invalid user names or e-mail
addresses to be submitted.

This issue only affects Drupal 6.x.

---- HARDENING AGAINST SQL INJECTION ----

A parameter passed into the node access API was not properly escaped or
validated before being used in SQL queries.  While there is no direct risk of
SQL injection from Drupal core, it's possible that this could have presented a
risk in combination with a contributed module.  Additional validation has been
added to eliminate this risk.

This issue affects both Drupal 5.x and Drupal 6.x.

---- VERSIONS AFFECTED ----

 * Drupal 5.x before version 5.15.

 * Drupal 6.x before version 6.9.

---- SOLUTION ----

Install the latest version:

 * If you are running Drupal 5.x then upgrade to Drupal 5.15 [
http://ftp.drupal.org/files/projects/drupal-5.15.tar.gz ].

 * If you are running Drupal 6.x then upgrade to Drupal 6.9 [
http://ftp.drupal.org/files/projects/drupal-6.9.tar.gz ].

If you are unable to upgrade immediately, you can apply a patch to secure your
installation until you are able to do a proper upgrade. The patches fix security
vulnerabilities, but do not contain other fixes which were released in these
versions.

 * To patch Drupal 5.14 use SA-CORE-2009-001-5.14.patch [
http://drupal.org/files/sa-core-2009-001/SA-CORE-2009-001-5.14.patch ].

 * To patch Drupal 6.8 use SA-CORE-2009-001-6.8.patch [
http://drupal.org/files/sa-core-2009-001/SA-CORE-2009-001-6.8.patch ].

---- REPORTED BY ----

The access bypass issue for translations was reported by Wolfgang Ziegler [
http://drupal.org/user/16747 ].

The validation bypass was reported by v1nce [ http://drupal.org/user/52144 ], supersmashbrothers [ http://drupal.org/user/241667 ], Tejus Pratap [
http://drupal.org/user/360600 ], and Limiting Factor [
http://drupal.org/user/373498 ].

The need for SQL hardening was reported by Derek Wright [
http://drupal.org/user/46549 ] of the Drupal Security Team.

---- CONTACT ----

The security team for Drupal can be reached at security at drupal.org or via
the form at [ http://drupal.org/contact ].



--
(Assignee)

Comment 1

9 years ago
Also, do we use the i18n module?
Assignee: nobody → buchanae
---- SA-CONTRIB-2009-004 - NOTIFY - PRIVILEGE ESCALATION ----

 * Advisory ID: DRUPAL-SA-CONTRIB-2009-004

 * Project: Notify

 * Versions: 5.x

 * Date: 2009-January-15

 * Security risk: Moderately critical

 * Exploitable from: Remote

 * Vulnerability: Privilege escalation

---- DESCRIPTION ----

A user triggering the cron processing of the Notify module may end up getting
logged in as another user when the Notify operations do not complete
succesfully.

---- VERSIONS AFFECTED ----

 * Versions of Notify for Drupal 5.x prior to 5.x-1.2

Drupal core is not affected. If you do not use the Notify module, there is
nothing you need to do.

---- SOLUTION ----

Install the latest version.

 * If you use Notify for Drupal 5.x upgrade to 5.x-1.2 [
http://drupal.org/node/358495 ]

Also see the Notify project page [ http://drupal.org/project/notify ].

---- REPORTED BY ----

Philippe Jadin and Bill Kennedy

---- CONTACT ----

The security contact for Drupal can be reached at security at drupal.org or via
the form at [ http://drupal.org/contact ] and by selecting the security issues
category.
I haven't seen the i18n module installed anywhere, I'll double check
(Reporter)

Comment 4

9 years ago
We don't use the i18n module
(Assignee)

Comment 5

9 years ago
but we do use Notify?
(Reporter)

Comment 6

9 years ago
No we don't use notify
patched, committed ( r21567 ), and tagged for prod ( r21568 )

over to IT (reed) for production push and please run updates.php

Thanks
Assignee: buchanae → server-ops
Component: spreadfirefox.com → Server Operations: Web Content Push
Product: Websites → mozilla.org
QA Contact: spreadfirefox-com → mrz
Version: unspecified → other

Comment 8

9 years ago
Awesome turn around :)
(Assignee)

Updated

9 years ago
Assignee: server-ops → reed
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 9

9 years ago
Doing sfx now, but can you get the rest of our Drupal instances updated asap, too?
(Assignee)

Comment 10

9 years ago
[root@mradm02 www.spreadfirefox.com]# svn up
U    modules/node/node.module
 U   modules/node
Updated to revision 21568.

No updates...
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.