The right arrow is visible when the location bar is empty

RESOLVED WONTFIX

Status

()

Firefox
Address Bar
--
minor
RESOLVED WONTFIX
9 years ago
5 years ago

People

(Reporter: Victor Porton, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121717 Mandriva/1.9.0.5-0.1mdv2009.0 (2009.0) Firefox/3.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121717 Mandriva/1.9.0.5-0.1mdv2009.0 (2009.0) Firefox/3.0.5

When the location bar is empty (no URL is typed), the green right arrow is visible. It should be not.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090115 Minefield/3.2a1pre

The locationbar is ready to type in. I see the same after deleting the URL in the locationbar, only useful if you want to type something in it.
Version: unspecified → 3.0 Branch
When you edit the location bar, the arrow shows, in 3.1 and trunk the location bar was enhanced and this bug doesn't really apply, unless you're actively editing the location bar.
OS: Linux → All
Hardware: x86 → All
(In reply to comment #2)
> When you edit the location bar, the arrow shows, in 3.1 and trunk the location
> bar was enhanced and this bug doesn't really apply, unless you're actively
> editing the location bar.
Or opening a new tab, which immediately focuses the location bar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [good first bug]
So basically, till you actually type something in there should be no arrow? This should be easy to do with css...

Comment 5

9 years ago
I'm not sure this is a good idea.  It might be visually distracting for the arrow to appear when you type the first character.

Updated

9 years ago
Duplicate of this bug: 474131

Comment 7

9 years ago
(In reply to comment #5)
> I'm not sure this is a good idea.  It might be visually distracting for the
> arrow to appear when you type the first character.
We could make a "disabled" version of the go arrow to be displayed?
ATM there is no arrow when the locationbar is focused. When you start to type in it appears, but when you delete all the text in it, it's still there. I think we should only display the arrow when a character/digit is typed in, right?
^ speaking about trunk, sorry.
As far as I have seen the arrow is just controlled with CSS. AFAIK there is no possibility in CSS to check if there is input in the locationbar.
That's correct. There's no pure-CSS fix for this. Given comment 5, I'm also not sure that this is a good idea at all.
Whiteboard: [good first bug]
I agree with comment 5 and comment 11, changing the urlbar contents when the user starts typing sounds like good recipe to distract him from his current task, and afaik we should avoid this kind of distraction per UX hint. The arrow is harmless, so the benefit would just be some polish, the cost is higher than the benefit.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.